1

Today I started trying to work from a network that uses the Airport Extreme version 7.7.1. Typically I use a VPN client (Viscosity) which gives me access to the various servers that my company runs on. I can connect to the open VPN without any issue but am experiencing mixed results from there forward.

Once connected to the VPN I can access a couple of the servers through a web browser and SSH from the command line but timeout while trying to connect to the rest. If I bypass the router and plug directly into the modem via ethernet everything works perfectly.

I've tried setting up port forwarding on the Airport Extreme with no success and disabling "Back to My Mac" settings. There are a number a threads out there where people have had issues with VPN and the Airport Extreme but nothing quite like this.

I'm baffled why I can connect to the VPN and some of the servers while others are failing. Again, I am sure that the VPN/servers are configured properly as this problem goes away when I remove the router from the picture.

Please let me know where I'm going wrong!

  • Can you isolate (or just focus) the problem to one particular VPN and look at the logs for that connection? Also, have you ruled out a firmware issue by trying an older or newer firmware on your base station – bmike Nov 4 '13 at 21:29
  • Thanks, I can definitely do that but I'm not completely sure which logs to check out and what to look for. I will dig around and post anything I can find. If you have any suggestions please let me know. Thanks again. – mcstupid Nov 4 '13 at 21:36
  • Your VPN client logs would be the first place to look. Secondary would be the server logs. Between the two, you should be able to pinpoint if it's a port blocked, timeout, or other common problem with VPN tunnels. – bmike Nov 4 '13 at 21:43
  • 2
    Ah, found it. The router was configured to use the same range of IPs as the VPN. With that config change made to the router all is well. I guess that explains the inconsistency. I can't answer my own question for 8 hours though. Thanks for your help and reminder the logs know all. – mcstupid Nov 4 '13 at 21:57
  • Do come back and answer.many others will end up in the same shape – bmike Nov 4 '13 at 21:59
1

The problem was that the Airport Extreme router was configured to use the same range of IP addresses as the VPN, so while I was able to connect to the VPN there was some issues when trying to SSH into some of the servers where there was an IP conflict. It is possible to change the "IPv4 DHCP Range" in the advanced network options of the Airport Extreme which solved my issue.

0

You have to enable IGMP Snooping on the Airport extremefor some reason. This worked for me and now my Cisco VPN works fine. Edit the Airport and go to the Network Tab and Network Options. Enable IGMP Snooping.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .