3

Is there a way to prevent Spotlight from indexing past versions of documents (see attached image). On my system it seems to always recommend an old version as the top hit, requiring me to scroll through or mouse over the results to get the actual document.

In case it matters, this particular example is a Numbers spreadsheet stored in iCloud.

Spotlight shows results from com.apple.documentVer…

  • 3
    Wow - I can't seem to get any of those items to be indexed on several machines. Have you tried flushing the database for your home folder? You would go into privacy settings for Spotlight and add your home folder and then log out. When you log in, you can remove the "restriction" and see if the index behaves better. – bmike Nov 4 '13 at 15:53
  • 1
    Interesting…I still get those entries, even with my home folder added to Spotlight privacy settings (though the actual documents themselves no longer appear, as would be expected). – starkos Nov 4 '13 at 19:10
  • 1
    A little more information: using Show All in Finder > Show in Enclosing Folder I was able to discover files live under /.DocumentRevisions-V100. But trying to drag that folder to Privacy gives "The item couldn't be added or removed because of an unknown error." – starkos Nov 4 '13 at 19:15
0

I ended up copying all of my documents (I didn't really have that many) out of iCloud to the local disk, and then deleting them from iCloud. The old versions were still showing up in Spotlight, so I added the entire drive to Spotlight's Privacy list to delete the index. Then I put the documents back into iCloud, removed the drive from the Privacy list, and let it sit for a few hours while it reindexed everything. After two days of usage everything seems to be working normally once again. Thanks to @bmike for the ideas.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .