10

I'm using a non-mac USB UK keyboard with Mavericks. Because Apple's idea of a UK keyboard is different to a non-apple UK keyboard, some symbols are wrong, e.g. " and @ are swapped.

How can I get set my keyboard layout to match a non-mac UK keyboard?

  • Have you tried the one provided by apple called "British PC"? – Tom Gewecke Nov 4 '13 at 14:14
  • British PC doesn't alway work, \ and ` were swapped for me, this new layout fixed that. – Dean Smith Jan 19 '14 at 11:19
  • 1
    What is the "this new layout" you are referring to? – Tom Gewecke Jan 19 '14 at 15:17
  • Just using "British PC" layout worked for me, as per @kdt's email below. Look what I can type correctly now: @`\# :) – noelicus Jan 28 '15 at 9:34
21

If the British PC layout from apple is not right, some alternatives can be found at

http://liyang.hu/osx-british.xhtml

  • 3
    These can also go in ~/Library/Keyboard layouts if you don't want to pollute /Library. Also didn't need to logout/in doing this. – Dean Smith Jan 19 '14 at 11:18
  • This also worked for me, with a Logitech K400 keyboard. It's still a cheap/nasty keyboard, but at least the key mapping is correct... – ianmayo May 24 '14 at 18:37
  • for the lacking in observation (like me, it took me 10 mins to see), you need to click on 'other' at the top to get access to these new maps. – DevDonkey Aug 2 '16 at 12:47
8

After downloading alternatives from the link suggested in Tomg's answer, I realised while making them active that there is already a "British - PC" layout installed by default.

To activate it was Settings->Keyboard->Input Sources->Plus sign & find it from the list, and then click the input source icon in the menu bar to select it.

  • 2
    British PC doesn't alway get everything right, for example \ and ` swapped. This one does. – Dean Smith Jan 19 '14 at 11:19
  • Do you really find that Apple's British PC does not put ` on the topmost leftmost key on an ISO keyboard as used in Europe? What is "this one"? – Tom Gewecke Jan 19 '14 at 15:25
4

To get this working correctly (without downloading anything extra) I had to go to System Preferences -> Keyboard -> Input Sources.

British was the only option I had there, but clicking the + icon brought up a list which included British - PC. Simply add that one, THEN remove the original British option using the - icon.

My keyboard was correctly mapped to the British default after that. It didn't work until after I removed the original British option, so only British - PC was in Input Sources.

  • This was the right answer for me without having to add anything else. While I was adding British - PC to my layouts, it was never "picking it up". I was, however, able to add other layouts (Irish in particular) and switching between them worked afterwards. – Sebastian Cruz Mar 13 at 21:22
2

I agree with the previous answers. Alternatively there is a software called Ukelele with which you can remap your keyboard as you like. I didn't find this answer before when I was looking for the "proper" British-PC layout. With the app it takes 5-10 minutes to redo your keyboard - there are ready-made samples inside which you can use as a templates.

I hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .