76

When in a browser (Chrome or Safari), the following keyboard shortcuts both launch the MacOS Mail app, and there doesn't seem to be any way to change or disable them.

Command+I

Command+Shift+I

Cmd-I / ⌘-I is particularly annoying because of course that is much more often used to italicize text.

Is there any way to disable this shortcut?

8
  • 1
    Does this only happen in Safari or also in other application?
    – nohillside
    Commented Nov 2, 2013 at 21:03
  • 9
    It's got even worse now. They've changed it in Yosemite to ⌘-I, when it used to work as a setting for forcing in-text type as italics when supported. It's the most inane shortcut ever. Who the hell needs to frequently email links to people? And whoever those annoying people are (i.e. my family members), I wish they would stop!
    – Benjamin R
    Commented Jul 16, 2015 at 5:28
  • 2
    The answer here solved it for Safari: discussions.apple.com/thread/251230865
    – Magne
    Commented Oct 26, 2020 at 15:33
  • 1
    A lot of people say that this can be solved by creating a custom keyboard shortcut for "Email This Page" that overwrites the default ⌘I -- but I've done this, and although the new shortcut shows up as changed in the Safari menus, ⌘I STILL OPENS MAIL. Argh.
    – Bowen
    Commented Jul 15, 2022 at 15:48
  • 1
    @Bowen Not sure I understand your recent edits. The original question was about Safari and Chrome, what is the idea behind removing the Chrome reference here?
    – nohillside
    Commented Dec 6, 2022 at 23:02

10 Answers 10

41

You can change the shortcuts from System Preferences:

If you want to disable the shortcuts, edit the NSUserKeyEquivalents dictionaries directly:

defaults write com.google.Chrome NSUserKeyEquivalents -dict-add 'Email Page Location' '\0'
defaults write com.google.Chrome.canary NSUserKeyEquivalents -dict-add 'Email Page Location' '\0'
defaults write com.apple.Safari NSUserKeyEquivalents -dict-add 'Email Link to This Page' '\0' 'Email This Page' '\0'

Then quit and reopen Chrome and Safari to apply the changes.

6
  • 1
    As of El Capitan, I no longer see anything but "All Applications -> Show Help menu" in that dialog. Commented Sep 16, 2016 at 22:34
  • 6
    In El Capitan, you have to hit the + button at the bottom, then in the dialog box that pops up, select Google Chrome from the Application dropdown. Fill in the Menu Title and Keyboard Shortcut as the screen shot above shows. Despite my comment below, this GUI method works for me again in El Capitan, but I'm still unable to disable this shortcut in Safari.
    – Dannid
    Commented Oct 5, 2016 at 16:16
  • 1
    Seems the "Menu text" in newer Chrome is Email Link. Changes should take effect while chrome is still running.
    – Andrew
    Commented Apr 20, 2018 at 7:10
  • 4
    Unfortunately, disabling the shortucts per your suggestion doesn’t work in Safari. It still gets triggered. Commented Jul 6, 2018 at 8:20
  • I've tried disabling this both by setting an alternative shortcut using the Keyboard System Preferences and also using the command line method above, but Cmd-I still opens Mail from Safari. So lame! (I'm running MacOS Big Sur 11.5.2)
    – Bowen
    Commented Sep 1, 2021 at 1:31
33

Taking a look at Chrome's keyboard shortcuts helps.

Cmnd+Shift+I is to "Email the current page". It's a bit annoying because it's so close to the developer tools (Cmnd+Opt+I).

4
  • I don't see this shortcut listed anymore on the link yet this behavior exists. Strange.
    – Zoso
    Commented Jun 15, 2021 at 7:53
  • 2
    By using this answer, you can make CMD + Shift + I open up Developer Tools. (Create a new Google Chrome shortcut with Menu Title: Developer Tools)
    – OJ7
    Commented Mar 31, 2022 at 21:30
  • @OJ7, this disables Chrome's default CMD + Opt + I, right? Is there a way to make them both open Developer Tools? Commented Aug 12, 2023 at 6:19
  • @DmitriiKuznetsov right, this replaces it. I haven't tried this, but you may be able to use this to create multiple shortcuts.
    – OJ7
    Commented Aug 14, 2023 at 15:48
8

I am a Linux user when using a desktop but OS X for laptops. My need is to insure that I have the same shortcut for the Inspector using Chrome. It was very inconvenient to have the Mail.app popup each time that I would confuse the shortcuts.

I should add that in order to make Linux closer to OSX I swap the control and the alt keys on the Linux side. This allows me to use Ctrl-c, Ctrl-v and many other shortcuts in the more ergonomic position of the command key, e.g. OS X Cmd-c, Cmd-v. In the pictures you will see that I have mapped Ctrl-Shift-I which would not make sense in the Linux side otherwise.

Here is my shortcuts setup

enter image description here

The important part of the setting is to know that the OSX shortcut must be mapped to the exact name of the menu entry. I stated that I am using High Sierra because "Email Link" is the menu label. This could also be dependent on the Chrome version I suppose. Make sure the spelling is identical.

The steps to reproduce are

  1. Apple Menu System Preferences ...
  2. Keyboard Menu
  3. Shortcuts Tab
  4. App Shortcuts from the left Pane
  5. Click the Plus sign under the right pane
  6. Select YOUR APP from the applications list, in my case Chrome
  7. Add the name of the menu label, in my case Email Link
  8. Add some shortcut you will not use, in my case Cmd-Shift-E
  9. Then, add another shortcut for the target operation, in my case Developer Tools
  10. Add the desired shortcut, in my case Cmd-Shift-I
0
5

The command-line solution given in another answer eventually worked for me but I needed to do one more thing:

after defaults write com.google.Chrome NSUserKeyEquivalents -dict-add 'Email Page Location' '\0', I entered the command: killall cfprefsd (and killall Finder for good measure).

This stopped the annoying Cmd-Shift-I shortcut on Chrome from creating a new mail message, but I can't get it to stop happening in Safari, unfortunately.

killall cfprefsd clears the preferences cache
killall Finder restarts the Finder

The GUI method described at the top didn't work at all for me, but maybe because I didn't clear the prefs cache.

2
  • This worked in El Capitan! Commented Sep 16, 2016 at 22:38
  • 1
    this doesn't work in macOS Sierra 10.12.5 and its really annoying.
    – xkeshav
    Commented Aug 2, 2017 at 5:13
5

Unfortunately none of the answers given here were able to prevent Command+I from triggering Email This Page in Safari for me (running macOS Sierra). The only way I have been able to prevent that behavior is by using FastScripts to map Command+I to an empty AppleScript. The script must be stored in ~/Library/Scripts/Applications/Safari to prevent it from disabling use of the shortcut for italics in other applications.

Unfortunately this approach has the side effect of disabling the use of Command+I to toggle italics in Safari where that is its default behavior, such as in Google Docs or in this answer box on AskDifferent. For me that's worth avoiding being thrown into my email inbox whenever I try to italicize text in a text box in Safari that doesn't support it.

1
  • Ideally the AppleScript could detect when ⌘I would cause italic behavior and somehow "forward" the shortcut in that case. I don't have time to figure out how that would work at the moment but I'd welcome any comments on how this might be achieved!
    – George WS
    Commented Jun 15, 2017 at 0:42
4

The accepted answer is not working on my MacBook Pro with macOS Sierra system.

I found a solution to disable Command+Shift+i in Chrome:

  1. Install the Chrome extension Shortkeys.

  2. Open the Shortkeys's preference panel, add a command+shift+i shortcut like below:

    Shortkeys for Chrome screenshot

  3. Restart Chrome.

Now you can say goodbye to the annoying Mac Mail!

3

You can also use Better Touch Tool to override the shortcuts (globally or for any specific application).

Given I was already using this app, it's been the solution for me since none of the other answers mentioned here worked for me (High Sierra), and I didn't want to install new software.

1
  • How did you exactly set this up in BTT? Commented Jul 6, 2018 at 8:11
2

The easiest way that I could find is to assign the keyboard shortcut to activate one of your installed extensions

chrome://extensions/shortcuts

1
  • 1
    This worked great! Fortunately I had an extension installed that would alphabetise my bookmarks on activation so there is no harm in activating that particular extension every time I use the wrong keyboard shortcut Commented Feb 28, 2019 at 22:37
2

The answer from Glorfindel worked great for me! I'm suprised that it's not voted much better.

To stop this pesky Mail app from launching you just need to assign it's shortcut (Cmd-Shift-I) to something else:

1) assign it to making a copy of the screen to the clipboard - it stops it in Safari, Chrome, Finder (looks like everywhere)

assigning to Copy Printscreen

2) assign it to launching Developer Tools in Chrome - the only disadvantage Mail will still be launched in Safari - you get Developer Tools always!

assigning to Developer Tools

1
0

The only solution that I've found to work for Safari is to change the default mail handler app.

I set mine to Safari itself, which isn't quite perfect but at least it means that Cmd+I (when not trapped by a handler for italics) doesn't open Mail.

As detailed in the top answer of Set default mail client in macOS without adding an email account? you can use SwiftDefaultApps to change the default mail app, as illustrated here ↓

Screen shot of SwiftDefaultApps preferences pane

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .