12

I have upgraded recently to Mavericks, and am setting up Time Machine on this system for the first time (it wasn't set up with the earlier OS, Mountain Lion.)

Time Machine successfully backs up once after I boot the laptop. However, every time it tries to back up again while the laptop is running (I don't normally perform a full shutdown and reboot very often!) it fails with the error message: "An error occurred while creating the backup folder."

Error message: "An error occurred while creating the backup folder."

I would like to eject the drive and plug it in again to see if this helps, but clicking the Eject button in Finder shows this message:

Unable to eject the Backup drive

and I have not wanted to do a Force Eject. I have rebooted, and Time Machine successfully backed up once after that, only to fail again the next time it tried.

I do sometimes close the laptop lid or put it to sleep with the disk still plugged in, and it is still there when it wakes.

I searched the Console for Time Machine-related errors but could not see any. (The Console won't display system.log saying I don't have permissions, but running syslog -C in the Terminal and scanning the output doesn't show anything either.)

How do I:

  • Solve the issue, so it successfully create the backup folder
  • Perhaps, see if it is Time Machine or another app that is preventing the disk eject?

Details:

  • An early 2011 Macbook Pro, which was running Mountain Lion for a week on a new internal hard drive, now Mavericks
  • The drive is a 2TB Toshiba USB drive. I formatted it at as Mac OS X Journaled. Running Disk Utility and verifying the disk shows no errors.
  • The drive has about 800GB free space.
  • I am running from a normal (non-admin) user account.
  • What partition system did you use prior to formatting the filesystem? – stuffe Dec 10 '13 at 16:16
  • Mac OS Journaled. – David Dec 11 '13 at 9:48
  • Apologies, I was not clear - before you create a filesystem you have to partition the drive up, you have a choice of "GUID partition scheme" or another one whose name escape me (I'm not presently near a Mac, sorry), you can find it in Disk Utility - this link shows some details (but is intended for a different problem) support.apple.com/kb/ht2434 – stuffe Dec 11 '13 at 10:02
  • Ah, ok! I used GUID Partition Table, since as far as I know it's the default and best. Does it make a difference to Time Machine which one is used? – David Dec 11 '13 at 13:28
  • 2
    I have this same problem. If you look at the apple discussion forums it is a common problem. No one has yet found a fix. Mine worked fine (with the same disk) for a few years, then about a year ago I started having this problem. The only fix is to force eject the backup disk, turn it off, then back on, time machine will work fine for about 24 hours, then complain about the backup folder. So you aren't alone :-) – Michael Oct 21 '14 at 16:23
3

I had the exact same symptoms with a Nov 2013 MacBook Pro (came with Mavericks already installed) using WD "My Passport" USB drives for Time Machine backups. The solution was to erase and reformat the external drives using Disk Utility as described in http://support.apple.com/kb/HT5911 under the heading "Erase and reformat the storage device".

I had a spare drive so, in order not to lose existing backups, I did the following:

  • erase spare drive as above
  • use Disk Utility to "restore" the backup drive's volume to the erased drive (you have selected the volume correctly (rather than the drive) if the Disk Utility window shows "First Aid; Erase; RAID; restore" as options not "First Aid; Erase; Partition; RAID; restore")

After this I have no problem doing multiple backups in a row, putting the machine to sleep without ejecting the backup disk and then doing a further backup, and no problems with ejecting the disk.

Good luck!

3

I ejected the backup drive by putting in the trash. Then I shut the drive down and plugged it back in. Waited for it to appear. After that I re-selected the disk as my backup and it seems to work fine. I had this problem before and did the same procedure and it worked until I installed Mavericks.

Can't figure out why Apple won't fix this problem as it's persistent every time I do a system update.

-2

I just resolved this error by rebooting my imac. After that Time Machine worked fine.

  • 1
    As I said in the question, if I reboot it works once and then stops again. However, rebooting is pretty inconvenient - and OSX isn't Windows where "just reboot" is an expected answer :p – David Dec 6 '13 at 11:09

You must log in to answer this question.

protected by Community Oct 11 '14 at 2:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .