I get this really damn annoying banner every time I plug in my iPad and sometimes when I build and go in Xcode it loses connection with the iPad for a second and reconnects straight away.

Anyone know how to get rid of this notification? I know my iPad won't charge on this Mac Pro, it predates the iPad so it has less power going through the USB ports.

enter image description here

  • This should only appear when connected through a USB hub—perhaps standalone, on a monitor, or in a keyboard. Have you verified that the issue persists when directly plugged in to the Mac Pro? – Christian L Nov 4 '13 at 6:24
  • Its an old mac pro, it has a lower amperage than the newer macs created after the original iPad was released. – David Wong Nov 4 '13 at 21:12
  • That does not change the fact that the alert should (note my original phrasing; it's not ambiguous) only happen when connected to a USB hub of some sort. That's why I asked a clarifying question that you have not bothered to actually answer. – Christian L Nov 5 '13 at 6:18
  • I'm plugging it into the computer directly, no hub, this isn't unfamiliar behavior, I already know it's not going to charge, it's a limitation with an old Mac. What I want is to get rid of the annoying notification. Previous iterations of OS X was not notifying on the computer at all, it would just show on the iPad that it wasn't charging, – David Wong Nov 5 '13 at 7:13
  • 1
    He's asking how to get rid of the message, not how to charge his iPad. – devios1 Nov 12 '13 at 17:57

To turn off notifications:

sudo defaults write com.apple.usbd NoiPadNotifications -bool YES
sudo killall usbd

To turn them back on:

sudo defaults delete com.apple.usbd NoiPadNotifications

Via Craig Hockenberry

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .