1

I have an iMac and a MacBook Pro. I recently upgraded both of them from Mountain Lion to Mavericks and now neither of them can “see” each other, despite both having File Sharing and Remote Login enabled in the “Sharing” section of System Preferences.

I used to be able to SSH into the other Mac, and the other Mac would show up as a device in Finder, but no more. Is this related to the SMB issue I’ve seen around the Internet?

What can I do so I can browse between my Macs via Finder and SSH again?

  • Have you restarted your network router(s) and/or switches? What sort of error messages do you see when you SSH? – IconDaemon Nov 1 '13 at 22:47
  • Yes. Restarted everything. SSH just timed out. Curiously, I’ve changed my router to use WPA instead of WPA2 and my Macs now see each other! Why is this? – Martin Bean Nov 1 '13 at 23:17
  • can you ping the other machine? – user151019 Feb 10 '14 at 13:32
1

From your question it sounds like you can ssh into the machine but not connect via Finder. This leads me to think this is a File Sharing setting, not a Remote Login setting as the two are independent. So my answer applies to File Sharing settings.

If you go to System Preferences, then Sharing and for the File Sharing service, choose Options...
By default Mavericks has Share files and folders using SMB and Share files and folders using AFP selected but no users selected under Windows File Sharing.

It also appears (in my testing) that with these selections, when you try to connect to another computer listed in the Finder sidebar, it attempts to connect using SMB and does not fall back to trying AFP if the SMB connection fails.

The answer I found was to either
a. Specify a user to connect with using SMB in the options... section of File Sharing in System Preferences
b. Specify sharing over AFP only, deselecting SMB sharing
c. In Finder menu select Go then Connect to server... and then in the Server Address: field enter something like afp://sharedcomputername.local
where sharedcomputername is the name of the computer you're trying to connect to.

  • I couldn’t connect via SSH, it just timed out. – Martin Bean Nov 3 '13 at 14:45
  • are you trying to connect over the ip or over the hostname - if you're trying with hostname it is a dns problem if you using the ip there is something with your router or firewall config wrong – konqui Mar 12 '14 at 15:09
0

Try this:

  1. Hit command K, to bring up the connect to server window
  2. Click the History button, it's to the right of the "+" button, a popup menu of all previous connections will appear.
  3. Click the server you want to connect to.

I hope this works for you.

0

Everyone may have figured this out but I was having the same issue with two Mac Minis inside the office, 7 others were fine after the upgrade. I did figure out that just changing your computer name seems to fix the issue, at least it did for the two problematic machines here. Removing the apostrophe should work because it ultimately changes the name.

Goto

  1. System Preferences
  2. Sharing
  3. Change Computer Name

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .