1

I have a Macbook Pro middle 2010. I had Mountain Lion till yesterday when I decided that today I would have "upgraded" to Mavericks.

With Mountain Lion everything worked fine until 5am tonight when I last used the wifi on that operating system.

So I backed up few files that I really needed and made a clean installation of the operating system. Everything went exceptionally fine and In a matter of an hour I found myself logging in into Mavericks.

Everything else works fine (as far as I can tell) but downloads and everything that it has to do with the internet connection is very very slow. The symptoms are:

  • Downloads started from browser often don't start on a lot of websites (Minecraft.com, Utorrent.com, etc). They are shown as they going with 0Kb/s for an hour or so). This happens with both wifi and ethernet connection.
  • YouTube videos refuse to load (the page loads, but the video stream is stopped at the beginning and doesn't go any further, ever) with wifi and loads very slowly with the ethernet connection.
  • Minecraft updates or dropbox synchronization are very very slow (takes hours to update few files or download the recent snapshot) even with a 7MB/s connection.
  • Speedtest.net says I have a download speed of 5Mbps and a ping of 72ms.
  • The Stack Overflow chat works very badly. Messages are synchronized slowly within long periods of time and messages sent by me are shown 2 times or shown in green (which means they were not really sent).
  • The Wi-Fi connection doesn't give me any error messages, and generally no particular messages are shown at all.
  • In Safari downloads start but they don't go faster than 2Kb/s.

    62 KB of 1.4 MB (2 KB/sec)

In the meantime here's the status of uTorrent:

uTorrent.dmg download

And here's the status detected by Speedtest.com:

Speedtest.net: Ping: 72 ms; Download: 5.01 Mbps; Upload: 0.32 Mbps

I've never had any of such problem earlier. I can recognize that there's a 5% chance that these problems are something else related, but to be realistic, I'm pretty sure that it is Mavericks or something linked to it.

How do I fix these problems?

  • I'm getting a similar problem on my late 2010 iMac. I don't have any trouble with my Macbook Air (2013) on Mavericks, just my iMac. It's also not a problem with my router, everything else works perfectly in my house (iPads, iPhones, Laptops, Xbox etc). Seems like a problem with 2010 machines. – user2804274 Nov 3 '13 at 16:24
  • Do you have the same problems with a wired connection? You can try and adjust the MTU value. This might solve the problem. – Saaru Lindestøkke Nov 7 '13 at 1:44
1

It happened that the last update (OS X 10.9 (13A603)) solved this issue on my Macbook Pro 13' of mid 2010.

You must log in to answer this question.

protected by Community Nov 9 '13 at 18:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .