30

Application switching cause one application to slide into another. Most times this is fine but am working on a MacBook Air and the slide transition causes motion sickness at times, especially after prolonged use (4+ hours). Looking for a way to turn off these animation.

Totalspaces2 has a turn off slide transition option, so I am pretty sure it's possible. Lion, Mountain Lion had Terminal commands for animation. I tried them all, and they don't work with Mavericks. I'm looking for Mavericks terminal commands to achieve the same.

1

There is no way to disable the animation but you might want to look at TotalSpaces, which replaces the builtin workspace manager. You can disable transitions altogether with this (as well as use different animations and layouts for spaces). It's not free ($18) but there is a 14 day free trial.

  • 1
    Dan is correct, for now there is no way to turn off the animations from terminal. I have tried TotalSpaces 2 (for mavericks), it does disable the animations but it does so by modding the OS itself. Wanted to point out that if you are only looking to disable the animations & not for spaces features, then TS2 trail version should suffice. Once the trial period ends the animation controls still work. – krok Apr 5 '14 at 17:23
5

In MacOS Sierra:

 - Go to System Preferences -> Accessibility -> Display 
 - Check in the box "Reduce motion".

This new function will speed up the animation between various display motion techniques such as using the mission control, switching desktops etc.

  • This seems to be the correct answer, at least in macos 10.12.6. – hoosierEE Oct 30 '17 at 16:45
-2

defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool NO

  • Although your answer may be a solution to the problem, you give no context on how the OP should execute this command, nor do you back up your solution with more explicative information and a link (or two) to authoritative sources where you discovered this solution. It may be deleted. – IconDaemon Oct 21 '15 at 11:32
  • It's also not the right command for slide transitions, but for window zoom – Tetsujin Oct 21 '15 at 16:59
  • This has no effect switching between full screen desktops using Ctrl+Left / Ctrl+Right arrow keys (aka "slide transitions") as mentioned previously – Mark Edington Mar 11 '16 at 16:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .