14

The usual method of using Quartz Debug doesn't seem to work anymore.

9

Running

sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true

nd restarting worked for me:

I only tested it with the internal display of an iMac though.

| improve this answer | |
  • 1
    Tried this already, doesn't seem to work for external display. – Rio Nov 6 '13 at 3:59
  • Doesn't work for me either. Trying to get an SEIKI 39UY04 be be readable. – Lilith River Feb 18 '14 at 18:40
  • It's works for me , macbook pro early 2008 and mavericks – user91306 Sep 19 '14 at 17:10
  • Worked on 10.9.5 MacBook Pro (late 2011) HD3000 with Dell P2815Q 1920x1080 @2x (3840x2160 native). Used "Display Menu" from app store to switch to mode. – karmakaze Jan 22 '15 at 22:17
  • Not working for an external Acer Predator connected over HDMI on Mojave – Andy Ray Nov 15 '18 at 17:00
5

actually it works on external displays such as TVs, but the list in System Preferences is limited. you can try two things:

the first one didn't work for me as it kept only showing "tv friendly" resolutions (720p, 1080p and 1080i). the second did indeed show 960x540 HiDPI i was after for my tv.

| improve this answer | |
  • 1
    I have a Dell P2415Q 4K monitor connected via DisplayPort/Thunderbolt, and holding alt revealed a previously hidden option called "1920 x 1080" that is actually 3840 x 2160 in HiDPI mode. – Andrew Watt Dec 12 '14 at 22:16
  • Pressing Alt did the trick for me – Travis Schneeberger Mar 24 '15 at 20:21
0

It seems to me that OSX is preventing TVs (or the other way around) from using HiDPI on non-scaling mode. For example if your TV is 1080p, the 960 X 540 HiDPI won't work, but 1280 X 720 HiDPI mode will (but it will be blurry because it is really running 2560 X 1440 on a 1920 X 1080 display).

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .