2

I installed Mavericks (upgrading from Mountain Lion) on my MacBook Pro (from early 2011) and the install seemed to go fine. However, this morning while I was working on PowerPoint, it switched off with no warning at all (it was connected to AC power and battery was full). Then, it refused to boot. After the spinning bar under the logo, it just gave a gray screen and was completely unresponsive. I tried to boot into safe mode by pressing ⇧ shift while booting and it reached a blue screen with vertical black stripes and was again unresponsive.

Then I tried clearing the NVRAM with ⌘⌥PR and it again reached an unresponsive gray or blue screen if I waited long enough. Tried Internet Recovery but after downloading something for an hour it again gave the blue screen with vertical stripes.

Any idea what I can do? Can I use a Linux LiveDVD or something to extract some data I have on it?

ETA: Ran the hardware test from the included Applications DVD and it did not find any troubles. Trying to boot with a LiveDVD did not work. Did get to the stage where I select from the range of boot options but then the boot did not complete. Tried with Ubuntu and CentOS.

  • What's your primary goal? If you need to do data recovery - ask that. Fixing the filesystem can and will delete files (or all the data if you have a severe problem). If you don't care about a slim chance fsck/disk utility will wipe files, boot into Recovery HD and use Disk Utility to repair the volume. – bmike Oct 31 '13 at 18:54
  • Primarily, I'd like it if the macbook booted. Booting into Recovery HD gives blue screen with stripes again. – Farhat Oct 31 '13 at 19:28
  • Definitely sounds like a hardware failure. The issue occurring after upgrading to Mavericks is probably just a coincidence. – bobbyalex Jun 24 '14 at 8:22
1

I would tackle this problem (as a last resort) by booting into the recovery partition of the machine in question and using the Terminal from there, copying every file/directory you need onto an external drive. Hopefully the drive isn't formatted as NTFS, but you will need to format it to FAT or HFS(+) if it is.

If you are familiar with the UNIX shell, you will have no problem backing things up from the recovery partition's Terminal. Once everything is backed up, format and reinstall Mac OS.

If you can't get into the recovery partition, a Linux LiveCD/LiveDVD may be your best option. I believe Linux can mount HFS+ drives for read-only (and perhaps write, I have not tried in a while). Boot into Linux, mount the drive and copy everything onto an external drive as I mentioned before (either using the shell or any GUI utilities they give you).

Once again, this should be a last resort. It will work this way, but will leave you with a clean slate.

Alternatively, you could restore from a Time Machine backup (from the recovery partition) if you have one.

  • Booting into the recovery partition is not working. It again reaches the blue-screen with vertical stripes sometime after taking the wi-fi info. – Farhat Oct 31 '13 at 19:13
  • 1
    Then you have few options other than using a distro of Linux to salvage what you can. Backup what you can using a LiveCD and then bring the machine to Apple - it could possibly be hardware failure as Dmitry mentioned. – aglasser Nov 1 '13 at 15:59
  • Apple hardware test says no troubles. Trying to boot with a LiveDVD did not work. It failed to boot and there were strange blue bars all over when it was booting. – Farhat Nov 1 '13 at 16:54
  • 1
    Apple hardware test has been unreliable for me in the past. Try booting a LiveUSB with Linux on it. If this fails too, I would bring it in to Apple and have them look at it for you. – aglasser Nov 1 '13 at 16:56
1

The blue screen with stripes is most likely a hardware failure / logic board / GPU error, but you could try booting the Mac into target mode (hold t at boot) and connecting it to another Mac over Thunderbolt (or Firewire) to see if the hard drive is readable.

Also, since recovery boot and single user mode boot are failing, two copies of the OS have failed to boot so it's not likely a software issue unless your Recovery HD broke long ago and Mavericks install didn't fix or detect that brokenness.

You could boot off an external source, but I'd seek repair assistance from Apple or a trained Mac technician unless that was unworkable for whatever reasons.

0

I have the same issue as you. It is a GPU failure. I have a solution for that which is I am using.

First reset the PRAM. It will boot with waves on the screen. The screen will go grey with no Apple logo. It will shutdown itself after sometime. Boot now and it will work. Download a software called gfxCardStatus. Change the GPU to Intel HD. Never use Flash or Phoroshop or any graphics heavy app.

If your Mac is stuck at Boot screen with the wheel, reset PRAM and follow the above instructions. It should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .