3

I have a desktop with two computers. On one side I have a Windows PC, and on the other side is a Macbook running OS X Mavericks that is plugged into a Thunderbolt display.

I use a wireless keyboard and a magic mouse. Today, I've been working on my Windows PC, and though my Macbook is booted up, I've left the screensaver running and I haven't touched any of my Mac devices.

Off and on, all throughout the day, the login window keeps popping up on my screensaver. It appears, time's out, disappears and within 10 seconds it appears again.

I've double-checked and nothing is resting on my keyboard and no cables are touching the magic mouse. I know the mouse isn't being bumped or jostled.

Would anyone happen to know if this is an OS X bug or, possibly, a bug with the mouse, sending in micro-movement data to the Bluetooth listener? If so, is there a fix?

I really like my Thunderbolt display. I'd rather not have screen burn-in from the login window constantly overlaying the screensaver, if I can avoid this.

Also, I am not looking to disable the login prompt from the screensaver. I work in an office and it is general practice to always lock your computer(s) when you step away from your desk. I need the login window to pop-up when I need to log into my Mac.

  • I'm having the same problem and it just started today. I changed some "Energy" settings, but when I used my hotkey to turn the screen saver on, after two images the log on screen appears. I have a Macbook running 10.9.3. I changed the settings back and it worked properly once, but then continued being a problem. I don't know what could have changed other than the energy settings that I changed back. – user79527 Jun 2 '14 at 0:23
2

I have the same problem, and it turns out it is being caused by Firefox. This seems unlikely, so I'll lay out the facts below.

At first, I assumed it was mplayer, VLC, or QuickTime player, all of which will disable the screensaver while they are doing their magic. Especially the first, which is installed via Homebrew and isn't properly written for OSX. However, much playing with these indicated they're not the problem.

Later, I guessed it was my attached bluetooth devices. So I've performed two experiments:

  1. I turned on my screensaver then powered off both the keyboard and trackpad, which are the only two input devices attached to bluetooth, yet the problem persists.
  2. I plugged in a USB mouse/keyboard then turned bluetooth off entirely from the OSX menu bar item. The problem persist even with bluetooth turned off entirely.

After some time, I guessed it was a USB device. I have several USB items plugged in, including several hard drives, a vape pen, and Android device. Unplugging these made no difference.

Finally, after the problem had been going on for several days, Firefox needed a security update and a restart. After restarting it, the screensaver/display sleep worked properly.

Now, whenever I have the problem, if I quit Firefox, the problem goes away. If I restart Firefox, sometimes the problem goes away, but sometimes it persists.

I have NO IDEA why Firefox would be triggering this, and if it weren't for the above facts, I wouldn't really believe it myself. If anyone else has this problem and uses Firefox, please try to corroborate?

  • I will flag it so a moderator moves it into comment. However, please summarize this, as it is probably too large for a comment – TheBro21 Dec 12 '15 at 18:18
  • Welcome to Ask Different. This seems fine to be something that moves the discussion forward even if it's not "the answer" Also, keep in mind we don't delete wrong answers since they often help as much as the right answer. – bmike Dec 12 '15 at 20:07
  • 1
    @TheBro21 Let's leave it in the answer section. It's how to troubleshoot and eliminate thins - also it's good thinking and might help others if not the OP on what to check... – bmike Dec 12 '15 at 20:09
  • I know "thanks" comments are discouraged, but thanks (anyway) for bumping the discussion. I eventually left the above-mentioned company and I now work from home. I still have the same general setup, but I don't lock my Macbook anymore. I'll continue to follow this discussion. Please post a real answer if you ever solve this and, yes, I remember googling for this solution being maddening as well! – RLH Dec 14 '15 at 12:42
  • What's hilarious is on my work laptop, somehow my screensaver activates after 5min (way too soon, and IT can't figure it out) so I literally have to run this special app called Jiggler that displays this behaviour ON PURPOSE. So on one machine I had to work hard to make this happen, and on another I'm working hard to stop it from happening. – philo vivero Dec 15 '15 at 22:18
0

I had the same problem on arch linux using Xfce Desktop and xscreensaver. The other comments here didn't help me.

Finally I found out that I had "presentation mode" (german: "Präsentationsmodus") switched on. That can be checked via the battery icon in the system tray of my desktop.

  • What has this to do with macOS? – user151019 Jul 17 '18 at 13:12
  • I had the same problem with Linux and since there is no real solution in the given answers I assumed that looking for a "presentation mode" would be helpful for those who stumble upon this issue as I did. – JUliSys Jul 18 '18 at 14:20
  • This answer might be out of place, but it sure did resolve my problem in the same setting (xfce + xscreensetting). Thank you! – Vedran Šego Feb 10 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .