4

After upgrading to Maverick, I can't use the open command anymore from the terminal. Whenever I do, I get:

$ open http://google.de
Trace/BPT trap: 5

This is independent on the document chosen.

$ open -a Safari
Trace/BPT trap: 5

I use homebrew as well, if this helps.

My .profile is as follow:

export PATH=/usr/local/bin:/usr/local/sbin:$PATH
# Finished homebrew

# export PATH=~/bin:xs$PATH

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

and my .bash_profile is

alias emacs="/usr/local/Cellar/emacs/24.3/Emacs.app/Contents/MacOS/Emacs -nw"

export PATH=/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/usr/local/git/bin:/usr/texbin:$PATH

## Homebrew
export HOMEBREW_GITHUB_API_TOKEN=6fb92887ac7d8317656501ec1193e05e0f360d01
export PATH=/usr/local/bin:/usr/local/sbin:$PATH
source `brew --repository`/Library/Contributions/brew_bash_completion.sh

##
# Your previous /Users/rainerkrug/.bash_profile file was backed up as /Users/rainerkrug/.bash_profile.macports-saved_2013-09-06_at_11:34:21
##


# Finally add ~/bin at first location in PATH
export PATH=~/bin:$PATH

# define EDITOR
export EDITOR="emacs -Q"

# define infopath to get correct info manual of org-mode
# export INFOPATH=$HOME/.emacs.d/org-mode/doc:$HOME/.emacs.d/ess/doc:$INFOPATH/

The open command is the correct one:

$ which open
/usr/bin/open

Any suggestions?

Rainer

  • Seemed to be working after a restart, but after starting emacs (installed via homebrew) not working anymore. – Rainer Oct 31 '13 at 10:47
  • Do you have some interesting messages in the Console app ? – Matthieu Riegler Oct 31 '13 at 13:44
  • Does the open command work with any applications other than Safari (or URLs)? For example: try to use open to launch TextEdit: open -a TextEdit. – Eddie Kelley Oct 31 '13 at 18:00
  • @MatthieuRiegler No - just the one I gave you. – Rainer Oct 31 '13 at 18:58
  • @EddieKelley Nope - did not work with any app. Nothing. It recognized if the app existed (so giving me the " app not found" message when the app did not exist), but the same error messages with all apps and types I tested. – Rainer Oct 31 '13 at 18:59
2

there. I had this problem and so I cleared out some old launchd plists, some of which dated back to Leopard (I restore via Time Machine when I get a new Mac.) So far, that seems to have worked. If you check out "man launchd" and scroll to the bottom, there's a list of folders where such files may be found. Leave anything by Apple, and clear out the questionable ones. I no longer have any Adobe software on my Mac, ditto for MS Office, and I'm trying ClamAV instead of Avast, so I cleared out all the Adobe, Microsoft, and Avast plists. Haven't even rebooted yet and suddenly I can use "open" reliably again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .