24

After upgrading to Mavericks the I-beam cursor in the terminal became less visible (see screenshot, I am using the Pro profile with a dark background)

enter image description here

Is there a way to change the cursor's color or to make it more visible? In the preferences I only managed to change the color of the text cursor.

  • I don't think this is possible, since you would have to change to OS cursor. – napcae Oct 31 '13 at 9:24
  • 3
    Try iTerm. Completely customizable. – 3Dave Feb 21 '14 at 14:38
  • 1
    @DavidLively Finally, a solution that actually works! I've been looking for this for years. I've always been looking to change the cursor. It never occurred to me just to get a better terminal app. Thank you. – SaganRitual May 31 '14 at 22:04
  • @DavidLively please make that a answer so we can close this successfully. – Ruskes Sep 17 '14 at 16:05
7

As many have mentioned above, I did this -

  1. Take a backup of existing ShadowedIBeam.tiff

    cp Terminal.app/Contents/Resources/ShadowedIBeam.tiff Terminal.app/Contents/Resources/ShadowedIBeam.orig.tiff
    
  2. Make your own cursor .... or, if you are a lazy one, just use this one - newShadowedIBeam.png (credit: Chris Dragon and his answer on this thread)

  3. Then copy it over the original ShadowedIBeam.tiff

    sudo cp ~/Downloads/TIbeam.tiff Terminal.app/Contents/Resources/ShadowedIBeam.tiff
    
  4. And finally, run this -

    defaults write com.apple.Terminal UseCustomIBeamCursor -bool YES
    

If you were as lucky as I was, you should have your eyes profusely thanking you in sheer gratitude!

  • The image you have linked to is a PNG file. I exported that as TIFF in Preview.app and followed the rest of your instructions. The cursor was not picked up on OS X 10.10.5 (14F27) – Douglas Held Nov 25 '15 at 18:22
  • The image embedded in the post is a .png, but the link ("this one") is for a .tiff, and works for me. – Symmetric Nov 25 '15 at 19:11
  • Running Yosemite. Worked great. Thanks. Note: If you don't copy over the existing file, but do a rm and mv, then you'll need to set the correct owner and permissions: sudo chown root:wheel ShadowedIBeam.tiff and sudo chmod 644 ShadowedIBeam.tiff – Wolfram Arnold Feb 1 '16 at 20:29
4

It looks like it was possible before Mavericks by editing

/Applications/Utilities/Terminal.app/Contents/Resources/ShadowedIBeam.tiff

I've tried changing that file, but it is never reflected in Terminal. I'd love to change this as I have a dark background color too.

3

Edit the cursor tiff image inside the Terminal App with for example Image editor (freeware)

Terminal.app/Contents/Resources/ShadowedIBeam.tiff

and then run

defaults write com.apple.Terminal UseCustomIBeamCursor -bool YES
  • I just tried Christian's answer on Mavericks and it worked. The key seems to have been that I used Photoshop to edit the .tiff, rather than GIMP or whatever. – tel Sep 15 '15 at 21:56
1

Same for me: Tried to edit ShadowedIBeam.tiff, with GIMP, but no effects whatsoever. What I did notice (with the file command). The original is a big-endian tiff, my modified version is a little-endian .tiff. In general I do know what little and big-endian is about, bu why would Apple distribute big-endian files on a little-endian (Intel!) machine??

I think it would be wise if Apple would an option to invert the colour of the I-Beam, nothing fancy or difficult about that!

  • Welcome to Ask Different! This does not really answer the question. If you have sufficient reputation, you may upvote the question. Alternatively, "star" it as a favourite and you will be notified of any new answers. If you have a different question, you can ask it by clicking Ask Question with a link to this question if it helps provide context. – grg Jan 19 '14 at 15:31
  • I think the endian analysis is worth keeping - even describing how to determine endian-ness of a tiff would be worth a bounty IMO. – bmike Feb 21 '14 at 15:48
1
defaults write com.apple.Terminal UseCustomIBeamCursor -bool YES
  • The cursor is different but not really readable – Matteo May 8 '15 at 15:29
0

This answer on superuser provides a solution where he has written an app available on github to customise the cursor to allow it to work with all apps.

I had been using iTerm for years but it did bug me where the terminal output could sometimes behave erratic I switched back to Terminal around snow-leopard or some-time after native terminal provided tab support.

0

You can do this with Mousescape: https://github.com/alexzielenski/Mousecape/releases

If you use Max Rudberg's Svanslös cursors, the I-Beam shows up nicely on a black background with the caveat that it gives you some other kind of weird flashy cursors. I believe you can create your own if you have the interest.

0

Based on the steps from Christian:

Edit the cursor tiff image inside the Terminal App with for example Image editor (freeware)

Terminal.app/Contents/Resources/ShadowedIBeam.tiff

and then run

defaults write com.apple.Terminal UseCustomIBeamCursor -bool YES

I used GIMP to accomplish this

  1. You can use GIMP to edit if desired (did this successfully)
  2. Click "open" in GIMP, Import from TIFF screen pops up
  3. On Import Pop-Up, click "Select All" and open as "Layers --> now "import"
  4. Do NOT change the RGB color profile, click "keep"
  5. Pick one of the layers to keep (big or small depending on what you want); delete the other layer
  6. Click on the "Colors" menu tab at the top of the screen and then click "Invert"
  7. Click on "File" and then "Export" --> export as "TIFF" file, save this copy in your documents and name it correctly ShadowedIBeam.tiff
  8. BEFORE YOU OVERWRITE THE ORIGINAL make a copy of it and also put this in your documents folder --> name it ShadowedIBeam.backup.tiff
  9. cp /Applications/Utilities/Terminal.app/Contents/Resources/ShadowedIBeam.tiff ~/Documents
  10. Copy the newly created Cursor file to the specified location, this step will overwrite the file inside the Terminal.app

    sudo cp ShadowedIBeam.tiff /Applications/Utilities/Terminal.app/Contents/Resources/
    
  11. Finally set the flag for Terminal.app to use a custom cursor

    defaults write com.apple.Terminal UseCustomIBeamCursor -bool YES
    

If the change doesn't take effect immediately (or after clicking around) then simply close Terminal app completely (CMD + Q) and then reopen Terminal.app

(tested on Yosemite 10.10.5)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .