1

In OS 10.8, you could set the keyboard layout for Japanese input in Kotoeri Preferences. The default was US, which generates the correct layout for a JIS hardware keyboard. In 10.9, Apple deleted this preference setting, and the keyboard layout is now set by whichever layout was most recently used. So now anyone who normally uses something other than US winds up with output that does not fit a JIS keyboard, unless they go to the trouble of switching to the US layout before they do so, which is major inconvenience. It seems like one should be able to fix this via some sort of .plist modification or "defaults write" command line input, but I can't figure out how.

Another way to put it is: How can one make US the default layout for Kotoeri input in 10.9, even when US is not on the list of user keyboards, but something else like French is.

  • If it turns out that nobody knows how to fix Apple's IM, a possible alternative Japanese IM is available at google.co.jp/intl/ja/ime – Tom Gewecke Nov 3 '13 at 20:57
  • defaults write com.apple.inputmethod.Kotoeri ridp -int 0;killall Kotoeri would set the romaji keyboard layout to U.S. in 10.8, but it doesn't seem to have any effect in 10.9. – Lri Nov 6 '13 at 19:46
  • @Lri Thanks! Yes I had tried changing the ridp key without any luck myself. I'm mystified as to where Apple has hidden the .plist setting which determines the layout for 10.9. – Tom Gewecke Nov 7 '13 at 19:21
1

This bug was fixed by Apple with update 10.9.1 of 12/17/2013

http://m10lmac.blogspot.com/2013/12/mavericks-update-fixes-japanese-input.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .