4

The following warning appears:

The document "tagsfiltersprogramandyou.key" could not be autosaved. The file has been changed by another application.

This happens both when I save and the autosave (which happens often). It is a modal box and interrupts workflow.

No other applications are running, and the issue survives program and operating system restarts. What could be causing this?

(This issue is new with Mavericks / Keynote '13).

  • Is it possible there is a background script modifying it? If not, I would check the extended attributes and ACL using Terminal. – ughoavgfhw Oct 31 '13 at 3:40
  • Any chance your system clock is wrong? – TJ Luoma Jan 25 '14 at 0:19
  • Oh, I forgot. Have you looked in Console.app for any warning/error messages related to the issue? If you're not the admin user, you may need to do this in Terminal.app: sudo egrep -i '(keynote|\.key)' /var/log/system.log – Jay Allen Jan 25 '14 at 0:19
3

The file might be being modified by another process. You can see as the file is accessed by various processes by running:

sudo opensnoop -f /path/to/file

Use the file normally, then attempt to save. If you get the error, check back in Terminal to see if any other processes have accessed the file.

  • I've checked for other processes that have it open; there never are any. – Zach Jan 29 '14 at 23:28
2

Use the fs_usage (man page) command to monitor, in real time, accesses to your Keynote presentation.

  1. Open Terminal (or iTerm, et al).
  2. Copy/paste the following into your Terminal window, replacing the word FILE with the filename of your Keynote presentation (keep quotes if your filename contains spaces or other non-ASCII characters):

    sudo fs_usage | egrep "FILE" # e.g. "My Preso.key"

  3. Open your Keynote presentation. In your Terminal screen, you'll see a bunch of output related to opening the file this like so:

    11:29:55  getattrlist       /path/to/My Preso.key           0.000003   Keynote.app   
    11:29:55  getattrlist       /path/to/My Preso.key           0.000005   Keynote.app   
    11:29:55  getattrlist       /path/to/My Preso.key           0.000005   Keynote.app   
    11:29:55  lstat64           /path/to/My Preso.key           0.000002   Keynote.app   
    11:29:55  getattrlist       /path/to/My Preso.key           0.000012   Keynote.app   
    11:29:55  getattrlist       /path/to/My Preso.key           0.000012   Keynote.app   
    11:29:55  lstat64           /path/to/My Preso.key           0.000006   Keynote.app   
    11:29:55  access            /path/to/My Preso.key           0.000013   Keynote.app   
    11:29:55  open              /path/to/My Preso.key           0.000016   Keynote.app   
    11:29:55  open              /path/to/My Preso.key           0.000007   Keynote.app

Then, do what you normally do in your spreadsheet. You may want to align your windows so you can see your Terminal window while you work. Whenever there's new output in your Terminal window, check the last column. It should normally say Keynote.app but if there's an access by any other process, you'll see it there and then you'll have your culprit.

  • If there's a Cloud Sync Client like owncloud, this might changed file attributes which Keynote interprets as a change... With fs_usage that should be easy to see. – k1th Jan 29 '14 at 11:22
  • Good idea. You could add |grep -v Keynote.app to show only the non-Keynote accesses. – beroe Nov 7 '15 at 16:35
2
+50

My thinking is that this is a permissions problem or a server problem.

Do you have any servers mounted?

If you save a file to your Documents folder does the problem occur?

Have you tried deleting and reinstalling Keynote?

Are you "sharing" the document so that Keynote has put it in your iCloud account?

Have you tried running Disk Utility and got it to verify permissions on your drive?

If you are having a permissions problem then I'd have a close look at ~/Library/Saved Application State/com.apple.iWork.Keynote.savedState and it's contents as well as any server you have mounted.

  • Actually, it looks like you may be right. See discussions.apple.com/message/16145573#16145573 and blog.chron.com/techblog/2011/09/… – Jay Allen Jan 24 '14 at 23:53
  • 1
    This one seems to be the most relevant, and provide the most insights. As far as I can tell, it is a combination of Finder + Dropbox that is causing the problem. If I have a Finder window open, I get this error constantly, if I don't, I don't. I'm guessing it is Dropbox updating the synchronized icon decoration. – Zach Jan 30 '14 at 18:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .