5

Before upgrading to Mavericks, I had a "Sharing only" account called "Shared" with a password, which I used to allow other computers to connect to my Mac. However, since upgrading to Mavericks, this account no longer appears in the "Users & Groups" System Preferences pane. I believe this is because it conflicted with the built-in "Shared" folder in /Users/Shared, so Mavericks probably had trouble with this account when upgrading OS X.

However, the account itself still works, with my old password. Is there a way to delete this account, even if it doesn't appear in "Users & Groups", without deleting the /Users/Shared folder (which is separate; the folder is part of OS X, and my "Sharing only" account has no Home folder).

4

I have had this issue as well and I found a solution: http://support.apple.com/kb/TS4404 on the Apple support website.

Just type the following two commands in terminal:

Quit and reopen System preferences and the sharing account will show up:

sudo dscl . create /Users/root GeneratedUID FFFFEEEE-DDDD-CCCC-BBBB-AAAA00000000

and then:

sudo dscl . create /Users/accountname UserShell /bin/bash

Replace "accountname" in the commands above with the missing account name.

  • While the first command was denied (eDSPermissionError), the second one worked and made the invisible user account show up in Users & Groups. – not2savvy Jan 22 at 12:20
1

This helped me a lot! Well, trying to add my 5 cents on the topic, if you need to list the user accounts from the Terminal you might issue the following commands:

Non System users with details

dscacheutil -q user | grep -A 3 -B 2 -e uid:\ 5'[0-9][0-9]’

All accounts (including system)

dscl . list /Users | grep -v ^_.* 
1

I am also using Sharing Only User Accounts in Mavericks.

You open System Preferences / Users & Groups, create a Sharing Only User Account and view it in the list of Users on the left side.

Then you quit System Preferences, open again System Preferences / Users & Groups and your new Sharing Only User Account is not in the list, you can't tell if it exists, you are unable to edit or delete it !

It seems that Sharing Only User Accounts are invisible except when they are created.

You can get around this user unfriendly feature by installing Apple's Workgroup Manager http://support.apple.com/kb/DL1698, which is able to manage all the users.

When you start Workgroup Manager, you get a connect dialog window where Address is the name of you computer.

I prefer this solution to sudoing in the Terminal.

Thanks to Greg

  • this doesn't work, unfortunately – Sarge Borsch Oct 16 '14 at 9:21
0

I'm having the same problem with a different account name, so it's not because you named it "Shared". If you download Apple's Workgroup Manager, you can delete the shared account from there. I'm still trying to figure out how to keep the shared account from disappearing when I create it, though. Strangely, I created one on my friend's machine in 10.9, and it worked fine. On mine, no go. I don't know what the difference is.

http://support.apple.com/kb/DL1698

0

Try adding a group in "Users & Groups". After that, my 'shared only' account reappeared in the panel...

  • Did not work here. – not2savvy Jan 22 at 12:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .