2

If I open an external drive, or an folder on that drive, in the Finder, then enter Time Machine by clicking on the menu bar icon and selecting "Enter Time Machine", then Time Machine runs, but it jumps me back to my User folder, rather than using the currently open folder that I have opened up on my external drive.

This problem does not occur if I enter Time Machine on my internal drive. Does anyone else have this problem? I think it started happening recently, perhaps after I upgraded to Mavericks.

  • 1
    sounds like you just don't have a time machine backup of your external. – Brad Allred Oct 30 '13 at 16:52
  • 1
    I definitely do. I am able to manually navigate to the drive or any folder on it and see its backups. – Gary Oct 30 '13 at 18:21
1

You need to open the backup drive as a different backup disk.

This can be accomplished from the Time Machine menu icon, click on it then press alt and the menu will change from:

enter image description here

to:

enter image description here

I would also recommend reading these excellent pages on Time Machine backups.

  • Wow this actually did the trick. I still think it's a bug in Mavericks though. This was not necessary before Mavericks. I only have one Time Machine backup disk, so when I choose "Browse other backup disks", only one option is available anyway. – Gary Oct 31 '13 at 15:50
  • I know there are loads of changes like that, like detect monitors now requires that alt be pressed as well. – Deesbek Oct 31 '13 at 15:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .