3

I have a 2009 iMac that I just upgraded to 10.9 OSX Mavericks and after migrating my old software over, my computer is having random kernel panics within 5 minutes of being booted up. Can anyone find any clues in the panic log below?

Tue Oct 29 18:56:03 2013
panic(cpu 0 caller 0xffffff80066ddd0f): "tcp_lock: so=0xffffff801355b7e8 NO PCB! lr=0xffffff800682fecf lrh= 0xffffff800681a7d6:0xffffff80068309f6 0xffffff8006811d13:0xffffff80068309f6 0xffffff800681a2c4:0xffffff80068309f6 0xffffff800681a2c4:0xffffff80066d6816 \n"@/SourceCache/xnu/xnu-2422.1.72/bsd/netinet/tcp_subr.c:2454
Backtrace (CPU 0), Frame : Return Address
0xffffff80861dbce0 : 0xffffff8006422f69 
0xffffff80861dbd60 : 0xffffff80066ddd0f 
0xffffff80861dbda0 : 0xffffff800682fecf 
0xffffff80861dbdc0 : 0xffffff7f88980225 
0xffffff80861dbde0 : 0xffffff80068308df 
0xffffff80861dbe10 : 0xffffff800681192d 
0xffffff80861dbe30 : 0xffffff80066dffa5 
0xffffff80861dbe90 : 0xffffff80066dfd5d 
0xffffff80861dbec0 : 0xffffff80066b5771 
0xffffff80861dbf20 : 0xffffff800644a15a 
0xffffff80861dbfb0 : 0xffffff80064d6aa7 
      Kernel Extensions in backtrace:
         com.apple.nke.applicationfirewall(153.0)[050FCA37-3ACE-343F-93DE-A42A92EF1AD9]@0xffffff7f8897d000->0xffffff7f88984fff

BSD process name corresponding to current thread: kernel_task

Mac OS version:
13A603

Kernel version:
Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64
Kernel UUID: 1D9369E3-D0A5-31B6-8D16-BFFBBB390393
Kernel slide:     0x0000000006200000
Kernel text base: 0xffffff8006400000
System model name: iMac12,1 (Mac-942B5BF58194151B)

System uptime in nanoseconds: 118627507779
last loaded kext at 33935262213: com.apple.driver.AppleHWSensor 1.9.5d0 (addr 0xffffff7f87e33000, size 36864)
loaded kexts:
com.seagate.driver.PowSecLeafDriver_10_5    5.2.3
com.speedbit.driver.vadriver    1.0.8
com.seagate.driver.PowSecDriverCore 5.2.3
com.apple.driver.AppleHWSensor  1.9.5d0
com.apple.driver.AudioAUUC  1.60
com.apple.driver.AppleTyMCEDriver   1.0.2d2
com.apple.driver.AGPM   100.14.11
com.apple.driver.AppleBluetoothMultitouch   80.14
com.apple.filesystems.autofs    3.0
com.apple.iokit.IOBluetoothSerialManager    4.2.0f6
com.apple.driver.AppleMikeyHIDDriver    124
com.apple.driver.AppleHDAHardwareConfigDriver   2.5.2fc2
com.apple.driver.AppleHDA   2.5.2fc2
com.apple.driver.AppleUpstreamUserClient    3.5.13
com.apple.kext.AMDFramebuffer   1.1.4
com.apple.driver.ApplePolicyControl 3.4.12
com.apple.iokit.IOUserEthernet  1.0.0d1
com.apple.AMDRadeonX3000    1.1.4
com.apple.iokit.IOBluetoothUSBDFU   4.2.0f6
com.apple.driver.AppleIntelHD3000Graphics   8.1.8
com.apple.driver.AppleMikeyDriver   2.5.2fc2
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 4.2.0f6
com.apple.Dont_Steal_Mac_OS_X   7.0.0
com.apple.driver.AppleThunderboltIP 1.0.10
com.apple.driver.AppleSMCLMU    2.0.4d1
com.apple.kext.AMD6000Controller    1.1.4
com.apple.driver.AppleLPC   1.7.0
com.apple.driver.AppleHWAccess  1
com.apple.driver.AppleSMCPDRC   1.0.0
com.apple.driver.ACPI_SMC_PlatformPlugin    1.0.0
com.apple.driver.AppleMuxControl    3.4.12
com.apple.driver.AppleBacklight 170.3.5
com.apple.driver.AppleMCCSControl   1.1.12
com.apple.driver.AppleIntelSNBGraphicsFB    8.1.8
com.apple.driver.AppleIRController  325.7
com.apple.iokit.SCSITaskUserClient  3.6.0
com.apple.driver.AppleUSBCardReader 3.3.5
com.apple.driver.AppleFileSystemDriver  3.0.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.BootCache 35
com.apple.driver.XsanFilter 404
com.apple.iokit.IOAHCIBlockStorage  2.4.0
com.apple.driver.AppleUSBHub    650.4.4
com.apple.iokit.AppleBCM5701Ethernet    3.6.9b9
com.apple.driver.AirPort.Atheros40  700.74.5
com.apple.driver.AppleAHCIPort  2.9.5
com.apple.driver.AppleFWOHCI    4.9.9
com.apple.driver.AppleUSBEHCI   650.4.1
com.apple.driver.AppleUSBUHCI   650.4.0
com.apple.driver.AppleACPIButtons   2.0
com.apple.driver.AppleRTC   2.0
com.apple.driver.AppleHPET  1.8
com.apple.driver.AppleSMBIOS    2.0
com.apple.driver.AppleACPIEC    2.0
com.apple.driver.AppleAPIC  1.7
com.apple.driver.AppleIntelCPUPowerManagementClient 216.0.0
com.apple.nke.applicationfirewall   153
com.apple.security.quarantine   3
com.apple.driver.AppleIntelCPUPowerManagement   216.0.0
com.apple.driver.AppleMultitouchDriver  245.13
com.apple.driver.AppleBluetoothHIDKeyboard  170.15
com.apple.driver.IOBluetoothHIDDriver   4.2.0f6
com.apple.driver.AppleHIDKeyboard   170.15
com.apple.kext.triggers 1.0
com.apple.iokit.IOSerialFamily  10.0.7
com.apple.driver.DspFuncLib 2.5.2fc2
com.apple.vecLib.kext   1.0.0
com.apple.iokit.IOAudioFamily   1.9.4fc11
com.apple.kext.OSvKernDSPLib    1.14
com.apple.iokit.IOSurface   91
com.apple.iokit.IOAcceleratorFamily 98.7.1
com.apple.iokit.IOBluetoothHostControllerUSBTransport   4.2.0f6
com.apple.iokit.IOBluetoothFamily   4.2.0f6
com.apple.kext.AMDSupport   1.1.4
com.apple.AppleGraphicsDeviceControl    3.4.12
com.apple.driver.AppleHDAController 2.5.2fc2
com.apple.iokit.IOHDAFamily 2.5.2fc2
com.apple.iokit.IOFireWireIP    2.2.5
com.apple.driver.AppleSMBusPCI  1.0.12d1
com.apple.driver.AppleSMC   3.1.6d1
com.apple.driver.IOPlatformPluginLegacy 1.0.0
com.apple.driver.IOPlatformPluginFamily 5.5.1d27
com.apple.driver.AppleThunderboltEDMSink    1.2.1
com.apple.driver.AppleGraphicsControl   3.4.12
com.apple.driver.AppleBacklightExpert   1.0.4
com.apple.iokit.IONDRVSupport   2.3.6
com.apple.driver.AppleSMBusController   1.0.11d1
com.apple.iokit.IOGraphicsFamily    2.3.6
com.apple.iokit.IOSCSIMultimediaCommandsDevice  3.6.0
com.apple.iokit.IOBDStorageFamily   1.7
com.apple.iokit.IODVDStorageFamily  1.7.1
com.apple.iokit.IOCDStorageFamily   1.7.1
com.apple.iokit.IOAHCISerialATAPI   2.6.0
com.apple.driver.AppleThunderboltDPOutAdapter   2.5.0
com.apple.driver.AppleThunderboltDPInAdapter    2.5.0
com.apple.driver.AppleThunderboltDPAdapterFamily    2.5.0
com.apple.driver.AppleThunderboltPCIDownAdapter 1.4.0
com.apple.iokit.IOUSBHIDDriver  650.4.4
com.apple.iokit.IOUSBMassStorageClass   3.6.0
com.apple.driver.AppleUSBMergeNub   650.4.0
com.apple.driver.AppleUSBComposite  650.4.0
com.apple.iokit.IOFireWireSBP2  4.2.5
com.apple.iokit.IOSCSIBlockCommandsDevice   3.6.0
com.apple.iokit.IOSCSIArchitectureModelFamily   3.6.0
com.apple.driver.AppleThunderboltNHI    1.9.2
com.apple.iokit.IOThunderboltFamily 2.8.5
com.apple.iokit.IOUSBUserClient 650.4.4
com.apple.iokit.IOEthernetAVBController 1.0.3b3
com.apple.driver.mDNSOffloadUserClient  1.0.1b4
com.apple.iokit.IO80211Family   600.34
com.apple.iokit.IONetworkingFamily  3.2
com.apple.iokit.IOAHCIFamily    2.6.0
com.apple.iokit.IOFireWireFamily    4.5.5
com.apple.iokit.IOUSBFamily 650.4.4
com.apple.driver.AppleEFINVRAM  2.0
com.apple.driver.AppleEFIRuntime    2.0
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.iokit.IOSMBusFamily   1.1
com.apple.security.sandbox  278.10
com.apple.kext.AppleMatch   1.0.0d1
com.apple.security.TMSafetyNet  7
com.apple.driver.AppleKeyStore  2
com.apple.driver.DiskImages 371.1
com.apple.iokit.IOStorageFamily 1.9
com.apple.iokit.IOReportFamily  21
com.apple.driver.AppleFDEKeyStore   28.30
com.apple.driver.AppleACPIPlatform  2.0
com.apple.iokit.IOPCIFamily 2.8
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.pthread   1
com.apple.kec.corecrypto    1.0
Model: iMac12,1, BootROM IM121.0047.B1F, 4 processors, Intel Core i5, 2.5 GHz, 4 GB, SMC 1.71f21
Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353637334648302D4348392020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353637334648302D4348392020
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380: 4.0.74.0-P2P
Bluetooth: Version 4.2.0f6 12982, 3 services, 23 devices, 0 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: WDC WD5000AAKS-402AA0, 500.11 GB
Serial ATA Device: HL-DT-STDVDRW  GA32N
USB Device: Hub
USB Device: IR Receiver
USB Device: Internal Memory Card Reader
USB Device: FaceTime HD Camera (Built-in)
USB Device: Hub
USB Device: BRCM2046 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: iMac, Apple Inc., 22.1

UPDATE: Just a quick update for anyone else who has this problem. The iMac was taken to the Apple store where they misdiagnosed the problem as a hard drive issue. After the hard drive was replaced, when I got home, the machine continued to crash just as it had before. I'm now going back to the Apple store.

PROBLEM SOLVED: It was simply some 3rd party software that was conflicting with OSX Mavericks, even though my mac was still crashing in Safe Mode. See the answer below for more information. Since the Mac still crashed in Safe Mode, within seconds of it starting up, I was unable to uninstall the 3rd party software. So, I had to take the machine to the Apple store, where they used some special equipment to keep it the Mac alive while they uninstalled the software, and it worked!!!

  • I have exactly the same problem, I tried everything and I feel hopeless right now. I think the only working solution is to go back to Mountain Lion. Mavericks seems to have many issues. – Kamil Boberek Nov 2 '13 at 14:43
  • @KamilBoberek Repeatable kernel panics on the order of evert 5 to 10 minutes are pretty trivial for engineering to fix. You are certainly entitles to decline to troubleshoot any problem and revert to the previous OS, but the hard kernel panics to diagnose and remedy are the ones that happen two or three times in 3 months and depend on tricky interactions and odd timing issues. – bmike Nov 2 '13 at 14:56
3

First, try starting the machine in Safe Mode to re-confirm that this is a third party software issue and not related to hardware:

  1. Shut down your Mac and wait 10 seconds.
  2. Press the power button.
  3. Immediately after you hear the startup tone, hold down the Shift key.
    You should press the Shift key as soon as possible after you hear the startup tone, but not before.
  4. Release the Shift key when you see the gray Apple logo and progress indicator (spinning gear).

To leave safe mode, restart the computer normally without holding down any keys during startup.

If it works fine in Safe Mode without issues, then you could try uninstalling some potential culprits seen in the log. The backtrace in your log shows the application firewall crashing. The key suspects in this case, based on what was loaded most recently, are the following:

  1. com.speedbit.driver.vadriver 1.0.8

    • Uninstall the Speedbit Video Accelerator for Mac from your system and see if it helps.
  2. com.seagate.driver.PowSecLeafDriver_10_5 5.2.3 and com.seagate.driver.PowSecDriverCore 5.2.3

    • Uninstall any Seagate Diagnostics Tool that you may have and see if it helps.
  • Thanks, but I have been unable to try your solutions due to the machine crashing immediately when in Safe Mode. – ac360 Oct 30 '13 at 15:07
  • One possibility, if OS X Mavericks is excluded as the cause temporarily, is that it's due to some hardware issue. You could run Apple Hardware Test to narrow down to hardware or OS as the cause of the issue. support.apple.com/kb/ht1509 – M K Oct 30 '13 at 15:46
  • Another thing you could try is to restore the system back to OS X Mountain Lion (if you have a Time Machine backup or a clone before the OS X Mavericks upgrade). That would also help a bit in isolating hardware or software as the root cause of the issue. – M K Oct 30 '13 at 15:48
  • Thank you MK. It's going to the Apple store today and they should go through all of this. Thanks again. – ac360 Oct 30 '13 at 16:47
  • MK, what you described was correct. The computer went to the Apple store again, they were able to remove the software and everything now works as it should. Thank you! – ac360 Oct 31 '13 at 17:33
4

This is hardly a hard disk issue; From the kernel panic, it seems the TCP stack is to blame, with no packet control block. The suspect is the firewall module, so what you might want to do is tell the Apple Store folk to disable the built in firewall NKE (Network Kernel Extension)

1

I had a similar issue, however I could boot in to safe mode and nothing crashed. However, if I'm not in safe mode crashing in 5 minutes.

This would happen even on the login screen if I waited for 5 minutes. This was before any user was logged.

I took my Mac Mini to the Apple Store and they were stumped. They showed me how to roll back to 10.8 via Time Machine and it's stable.

I've been uninstalling software, upgrading apps, and running any disk optimization tools.

I haven't tried to re-install Mavericks yet to see if anything has changed but I'm not hopeful.

  • Interesting. Would you explain in broad terms how you rolled back from 10.9 to 10.8? – bmike Jan 17 '14 at 1:40
  • 1
    If you're using Time Machine, you just boot up with Time Machine, choose a backup from 10.8, and restore. support.apple.com/kb/ht1427 – TwisterMc Jan 17 '14 at 13:05
1

com.seagate.driver.PowSecLeafDriver_10_5 5.2.3 com.speedbit.driver.vadriver 1.0.8 com.seagate.driver.PowSecDriverCore 5.2.3

these appear to be the problem. find out what they are and uninstall.

0

I had the same problem after installing this Video Accelerator App (which is more of a malware to me) and solved it following these steps:

  1. Reboot your computer, click on the icon of VA on the menu bar and select: Video Accelerator off.
  2. Open Terminal, run su and type your root password.
  3. Run cd /System/Library/Extensions, then rm -rf VADriver.kext
  4. Reboot your computer and use the App uninstaller to remove it from your Mac completely.
-1

I think it is the MAC Family Tree 7.0.3 which is causing the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .