3

A couple of people on twitter share this issue, but I cannot find any discussions of it nor solutions.

Since moving to OS X 10.9, Reminders app keeps pinwheeling, and won't respond. It doesn't crash, so I have to force-quit it. This happens on both my 2008 iMac and my 2013 Air. On my Air, I can tell something weird is happening because upon launching Reminders the fans kick on loud.

The data seems to be syncing fine from iCloud, so it doesn't look like a sync issue is causing this.

Any ideas about what could be causing this issue and how to fix it?

2
  • 1
    Seeing the last couple comments I would just like to re-iterate that, according to the voted answer and my own tests, this problems relates ONLY to "null" location reminders, NOT ALL location reminders.
    – user55101
    Dec 2 '13 at 12:28
  • For me, I deleted the "null" location reminder, but the issue persisted—so, I deleted all location-based reminders and the issue was resolved. Perhaps it was not the same issue. Mar 24 '14 at 15:55
4

I started to do the same as mentioned above -removing all location-based reminders including completed ones... (had to go directly to iCloud.com)

As I was going through, I found one that had "location: null", deleted it (or just removed the location part of it) and then, before deleting any more, tried my reminder app on my Mac computer (running Mavericks that wouldn't open/crashed). AND IT WORKED

So to be clear, you don't have to delete ALL location based reminders -just any that happen to have "null" in the location which, of course, messes with it's head! (I must've bumped it on/not done it right).

1

I can confirm that deleting all location-based reminders fixes the problem.

You have to delete all location-based reminders, including those in the Completed list.

The next time I launched Reminders, it popped up right away.

1

I had a similar problem after upgrading to OS X 10.10 Yosemite. The main window would not appear after launching the Reminders app. Clicking again on the icon on the Dock would cause the window to show up and the left pane did contain my reminders lists but the right pane where the actual reminders should show was blank. The window was also unresponsive to clicks.

I logged into icloud.com to take a look at my location-based reminders as Daniel suggested but I wasn't able to identify any that had a location listed as null. I decided to create a new reminders list, drag all of my uncompleted reminders to it (none of which had locations), and then I deleted my original reminders list to get rid of all of my completed ones. So I never actually found the offending one but that fixed the problem for me -- I can once again open the Reminders app on OS X.

0

It seems to be caused by location dependant reminders. Worked fine for me until I added an at location reminder on my iPhone. Removing the reminder from iPhone "fixes" the problem on Mavericks!

1
  • As in, removing all my reminders on my iPhone, or just the location-based ones? Nov 11 '13 at 21:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .