I just upgraded to Mavericks on my new Macbook Air and I am facing issues downloading apps from the Mac app store.

When I click on the install button on any app, it does the usual animation of jumping into the Application folder and then the button immediately says installed. If you go to the dashboard you can see the new app icon with the progress bar inside it which has moved all the way to the end and the cancel button on the upper left corner. It remains this way forever.

No it doesn't matter if the app is big or small; it always behaves this way although I have had random apps succeeding.

The problem is not just the fake complete notification, the app never gets installed and sometimes it gives an error saying that the download failed and asks me to retry again from the purchases menu in the App store.

I have even done a complete re-installation of Mavericks but it did not help.

PS: The first time I upgraded to Mavericks, I was able to download Pages and iPhoto without any issues. The problem started sometime after that.

1 Answer 1


I spent a long time with customer support on this; several weeks actually.

One of the things you can try is to remove the folder that is listed in the console log when the issue happens. To do this, open console and leave it running. Next attempt the download and when you get the failure message, go back to console and you will see entries which say that system was unable to access a folder. Using finder, open the folder just above the folder that is named with a random sequence of strings.

For eg: file:///var/folders/nc/qmbww7hd0cl24ylyqnldqxv80000gn/C/com.apple.appstore/409183694/mzps155989934935175015.pkg#Keynote6.pkg

In the above case, delete the folder nc. Make sure the appstore is closed when you do it. Restart the computer after this.

But what really fixed the problem for me was a very simple change.

Click on the wifi symbol on the menu bar and click open network preferences. Click on the location drop down and click edit locations. Remove all the locations in the resulting window and create a new one with a completely new name.

Restart the PC and connect to your network and attempt the download again. This fix is what worked for me. In case you have the same issue, try it out and let me know if it worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .