1

Ever since I upgraded my main machine to Mavericks, every time I open a new app, two things happen:

  1. the app takes a long time to open;
  2. the whole system slows to a crawl until the app opens completely.

The interesting part is that this happens on an early 2011 MacBook Pro (with 4GB of RAM), while on an older machine (mid/late 2007 MBP with 2GB of RAM), also updated to Mavericks, everything is a breeze—it’s surreal! (Both machines were upgraded from Snow Leopard.)

And on top of that, Safari is completely broken—see my previous question.

What I’ve done so far:

  • repaired permissions;
  • cleared system and user cache;
  • reseted the SMC;
  • ran AppleJack;

What can I possibly do to make it work as it should?

  • Does this happen with every application, or just a select few? – JW8 Oct 29 '13 at 20:03
  • 2
    Have you checked the disk for errors ? My 2012 MBP is faster than Mountain Lion with Mavericks. – Pratik Oct 29 '13 at 20:05
  • @JW8 As far as I can tell, with every application. And also, it happens every time I open them, not just the first time after a fresh restart. – Alex Oct 29 '13 at 20:16
  • @PratikaRana It was part of AppleJack set of utilities, so yes. – Alex Oct 29 '13 at 20:18
  • There are 2 great tools to start with debugging. One is the Activity Monitor to see who, what, the second one is the Console log. – Ruskes Apr 23 '14 at 14:47
1

When I see things like this I often suspect disk problems. (This is a HDD, correct?) The first symptoms of soft disk errors are often bad performance.

Open the Console and see if you see any disk errors. Also try booting into a Super Duper clone. Since a clone will have the same files, any problem would continue if it were a configuration problem. But if the problem goes away, it was likely a problem with the physical drive. As a bonus, a clone is exactly what you will need if you have a physical drive problem.

0

I suggest you reinstall the application. If all goes wrong, then just reinstall Mavericks. My MBP (mid 2012) takes FOREVER to start up but the apps work just fine.

0

I would suggest clean install of Mavericks (make sure you back up your data first) from a bootable USB install drive.

There is also step by step guide available.

  • That’s one thing I’m trying to avoid. – Alex Feb 6 '14 at 16:27
0

I did a clean install. The first day it was o.k., but then opening apps takes a long time, watching the bouncing app-icons in the dock.

  1. Mavericks fresh install (external HDs kept disconnected, two displays attached)
  2. iWork (from CD)
  3. Adobe CS4
  4. iCloud activated
  5. Canon printer driver

After i gave up when recurring the old behavior i installed back much other stuff, it can´t hurt anymore. Watching the ever bouncing app-icons in the dock, again. Crap.

-1

Buy a solid state drive. Yeah, I know, expensive but EXCELLENT. If you want an external usb 3 make sure the case has UASP. Very important.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .