I'm running OS X Mavericks on a computer with two displays that are not mirrored.

One of them is configured as the primary display using the menu bar location in Displays System Preference, pre-Mavericks style. (Although both displays actually have the menu bar.)

Problem: cmd + tab Task Switcher sometimes appears in secondary display instead of the primary. Once it starts appearing on the secondary display, it might soon move back to the primary, too.

Questions:

  1. Why this happens? I have seen it happen more than once but haven't yet figured out the pattern.

  2. How to configure the task switcher to appear only on the primary display?

Edit:

According to similar question How to choose on which display Application Switcher shows?, the behavior depends on which display has the dock. Follow-up variant question:

2'. How to configure the dock to appear only on the primary display?

I answered a similar question here - cmd-tab behavior on Mavericks with multiple displays

The Task Switcher does follow the Dock. If the Dock is on screen 1, the Task Switcher will appear on screen 1. If the Dock is on screen 3, the Task Switcher will appear on screen 3. Etc.

To make your Dock appear on a screen you can use a couple of methods.

Method 1 - Move your mouse to the bottom of the desired display. Don't stop once you reach the bottom of the display though, try to move it further down, as if you're pushing down on the bottom of the display with your cursor. This action tells the Dock to move to this display. This is temporary however, meaning the Dock will stay on this display until you perform this action on another display or reboot your Mac.

Method 2 - This will change the default starting point for your Dock. In System Preferences > Displays > Arrangement you can drag the menu bar from one display to another in this windows display icons. See the attached picture for reference. This alters the default preference to always show the Dock on the desired display, the one you drag the menu bar to in this preference pane, when you boot and/or login to your user account. You can still use method 1 to temporarily change the Dock's location but upon a reboot it will return to the display specified here.

System Preferences > Displays > Arrangement

  • 4
    Oh! I must be performing Method 1 on my non-primary display subconciously. Is there a way to disable this long downward drag dock-switching behavior? – Ryan McGeary Feb 27 '14 at 18:33
  • @RyanMcGeary - If I understand you correctly you want to have the menubar/task switcher default to the main display without having to drag down to summon the dock. If so, use method 2, this defaults to the chosen display whenever it's connected. – Mr Rabbit Feb 27 '14 at 20:26
  • 3
    @MrRabbit I suspect he wants it to always stay on the primary display (ie disable Method 1) - see superuser.com/questions/665004/… – Cebjyre Feb 28 '14 at 5:22
  • 5
    Note: you want the dock to appear at either the top or the bottom for this to work, if your dock is on the left, then the task switcher would always appear in the left-most monitor, same thing if you have it on the right. – Zinan Xing Jun 5 '15 at 17:31
  • 1
    Thanks! Good to know about (1). I had set (2) and couldn't figure out why the Task Switcher kept appearing on my secondary monitor. Seems like we'll just have to remember to use (1) to pull it back to primary whenever it goes wandering. – And Finally Apr 18 '16 at 11:03

Great question!

You answered #1 yourself - that is, the Switcher appears on the monitor where the Dock was last shown.

To change it, just move the mouse to the bottom of the display that you want to show the Task Switcher on (this will temporarily show the dock on OS X Mavericks, until you move the mouse away from the bottom of the screen).

Dock pops up when mouse at bottom of screen

Now the Switcher will appear on that display, until the Dock is shown on one of the other displays.

Now, how to configure the Task Switcher to appear on the display with the mouse pointer? That's what I want to know. ;-)

  • I have the same problem. You're right that the task switcher follows the Dock, but I can't ever make the Dock appear on the secondary display; I move my mouse to the bottom and nothing happens. – Elliott Nov 24 '13 at 3:30
  • Are you using Mavericks (OS X 10.9)? Under System>Preferences>Dock, there is an Automatically hide and show the Dock checkbox. – Brent Faust Nov 24 '13 at 17:32
  • Yes I am using Mavericks. The problem is, the Dock occasionally moves itself to the non-primary display, and I can't move it back. I know about that checkbox, I've tried both with and without autohide. You said you can move the dock between displays by moving the cursor to the bottom of the screen; that doesn't work for me. – Elliott Nov 24 '13 at 20:46
  • Ah, that is strange. It works for my 3 and 4 monitor setups. Try unchecking that checkbox. Then when you move the cursor to the bottom of the screen, the Dock is moved to the bottom of that screen (where it remains). – Brent Faust Nov 24 '13 at 22:02
  • 1
    Surprisingly, for the ADD crowd, reinforcing that, "the Switcher appears on the monitor where the Dock was last shown" was actually very helpful. Somehow I was unaware of that. – Dan Rosenstark May 3 '16 at 19:12

As the OP and other answers have noted, the Task Switcher follows the last-moused-over dockbar.

Fixing the Issue

To eliminate this behavior in all cases, hide the menu bar on your secondary monitor:

  1. System Preferences
  2. Mission Control
  3. Turn Displays Have Separate Spaces to OFF

Of course this will impact your use of Spaces with multiple monitors, but it might keep you sane.


Duet Display & Arrangements with Strange Behavior

Another strange note is that if you have a Display that is seen below your primary display in the Arrangement View -- like this example using Duet -- it will get the Dock, and therefore the switcher. Move it to the side or above to avoid this.

enter image description here

Edit

Just realized that I've been here before and it's just above! The answer is:

don't put the Duet "below" your other display in the arrangement!


I'm having this issue right now. I'm on Sierra with Duet Display (Thunderbolt primary screen + Duet on iPad mini). All the options (including shutting off Displays Have Separate Spaces do not help. The Menu Bar is on my primary display, yet the dock and task switcher are on the iPad mini.

The only workaround I have for now is to put the dock on the right or left. Very weird!

enter image description here

None of the above methods worked for me, but I tried unchecking and re-checking

Dock > Automatically hide and show the dock

and it seemed to fix it for me. Task switcher is back to the correct screen.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.