3

Ever since upgrading to Mavericks from Snow Leopard, Safari’s default User Agent is set to custom. Anybody has any idea why this happens? And how can I fix it?

enter image description here

  • 1
    Do you have activated the developer menu? Do you see a menu "Develop" in your menu bar if safari is active? If so, what did you have chosen as User Agent in that menu? – napcae Oct 29 '13 at 9:23
  • Yes, I do, and the default User Agent is “Custom”. Every time I start Safari, it chooses “Custom”. – Alex Oct 29 '13 at 9:25
  • Did I understand that correctly: If you chose Default now, then restart Safari, the User Agent resets to "Custom"? That is not intended, normally it should always reset to "Default"(That's why it's called default") – napcae Oct 29 '13 at 9:30
  • @napcae, you understood correctly. – Alex Oct 29 '13 at 9:34
3

I managed to fix it by deleting the CustomUserAgent string in the plist file.

defaults delete com.apple.Safari CustomUserAgent

But I still don’t understand how it got to be like that in the first place.

  • This bothered me for the longest time. It could be that I once changed as instructed by coursera. Not 100% sure. – Hauke Nov 19 '14 at 16:10
0

This happens after you use defaults write com.apple.Safari CustomUserAgent "\"My user agent string\"" command. Either your or someone who used your computer wanted to add a permanent user agent string to the browser. It not only adds the string permanently but also setting it to the default string. You can add a new string to overwrite it as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .