4

Since upgrading to OS X Mavericks, when I want to mount an ISO file that's on my Mac from my Windows 8.1 PC (so, mounting a Mac share on a Windows computer, so I am accessing the file from the Windows PC), I get an error saying it can't mount it. I have to copy the file to the PC to mount the ISO file.

Is this due to how Mavericks switched from AFP/SMB to SMB2? Is there a way to fix this?

  • I don't think this is an SMB issue, as I can no longer mount ISO 9660 in OS X at all anymore. I think it is related to them removing the dvd-rom. – user69880 Feb 8 '14 at 21:40
  • Hmm - Every Mac without a drive supports remote disc and Apple's USB SuperDrive, so the drivers are clearly still shipping. – bmike Feb 9 '14 at 1:02
  • What is the share address you are accessing? You can't mount a Mac share in Windows because Windows doesn't support the AFP type instead you could try ftp, cifs, or smb as they are more Windows friendly. – Andrew U. Mar 13 '14 at 11:22
  • I'm using SMB to connect. – Gary Mar 14 '14 at 17:30
1

It sounds more to me as if it's a Windows issue than a macOS issue, even though I realize that it didn't start until after the Mavericks upgrade. Have you tried any other mount tools, such as CloneDrive or PowerISO? It may be worth trying a couple of other tools as a test. Are you able to mount the ISO from another Mac?

0

I'm not sure if it's the use of SMB2 that's causing the problem but something that may be worth trying is mounting the share using SMB instead of SMB2. To do that, specify the server as cifs://server instead of smb://server when mounting via Finder.

  • I'm not mounting a Windows share in Mac, though. I'm mounting a Mac share in Windows. And in Windows Explorer, I already tried mounting with smb:// rather than \\SERVER-NAME\, but then Windows says there isn't an app that can handle smb://. Which is strange since I think in Windows 8 (but not 8.1), Windows Explorer handled smb:// just fine. – Gary Oct 29 '13 at 15:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .