3

I have the latest version of Macbook Air with Mountain Lion, as of Oct 2013, and since one of the computers is an older one that needs WEP, the Linksys (Cisco) router is set to support both WEP and WPA.

However, with the Macbook Air, when the "cisco" is chosen from the list of Wifi connection, it keeps on saying, "Enter the password for WEP", and even if we enter the password, it won't connect.

What we have to do is, use "Join Other Network", and type in "cisco", and choose WPA or WPA2 Personal, and then type in the password, and it will connect, but the thing is, sometimes the network drops, or after the computer is rebooted, we will have to repeat the same steps again -- it won't remember the settings to auto connect (using WPA).

Is there a way to make this work more smoothly?

  • Not entirely shure if this is a OS X problem. Did you tried it with other computers? What are those choosing when connecting to the WiFi? – napcae Oct 29 '13 at 9:18
  • at least I connected using WPA2 Personal and it worked and when I rebooted, it doesn't work, which my cousin Vinny can handle better if he is to do the connection instead of OS X – 太極者無極而生 Oct 30 '13 at 15:25
1

I set the Linksys (Cisco) router so that all the 2.4GHz and 5GHz support essentially the same thing: WPA Personal and it seems to work fine now.

I think the issue was 2.4GHz and 5GHz was set to WEP and WPA, respectively, due to some 2.4GHz device using different security standard. So I think the Mac might have some issue of not able to remember the connection, being confused by difference in settings of 2.4GHz and 5GHz.

  • 1
    Change the SSID/network name of the 5 GHz (WPA) one. – samh May 20 '15 at 2:20
0

delete the WiFi net from the SystemPreferences->Network->Advanced->WiFi list. then reinstall it.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .