2

I made the mistake of upgrading to Mavericks and now my Samsung ML-1710 won't print.

I get Stopped - 'Filter' failed while trying to print a test page for example.

I've tried some of the suggestions here which are in regard to an Epson printer. I've obviously deleted and added the printer numerous times, verified the permissions using disk utility (it did make some corrections), tried a different Gutenprint driver (ML-1750) that didn't work, etc.

Is there anything else I can try?

Thanks!

1

I got it working on my Mavericks Macbook Pro this morning. All you need to do is install SpliX 1.1.1 (a set of free CUPS printer drivers for certain models of Samsung, Dell and Xerox printers) at http://guigo.us/mac/splix/

Then, reset your printing system (http://support.apple.com/kb/ht1341) and re-add the ML-1710 1.1.1 driver.

Then you're good to go!

  • I'll try this out later tonight, thanks for giving me hope! – jdb Oct 30 '13 at 15:53
  • splix wont open as my mac says its from a third party unidentified developer ?? – user68108 Jan 21 '14 at 2:17
  • @Pieter please see this to solve your problem: apple.stackexchange.com/questions/58509/… – Ian C. Jan 21 '14 at 2:34

You must log in to answer this question.

protected by Community Jan 21 '14 at 2:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .