2

I get a message in the Image Capture window saying: No camera or scanner detected.

Scanner worked with Mountain Lion, but is not working with Mavericks. On Canons website, this is the message on Canon's MP780 for Mavericks OS: "There is no driver for the OS Version you selected. The driver may be included in your OS or you may not need a driver."

I know the hardware (Canon MP780) works as I tried VueScan, and the hardware scanned with this program - but I would have to pay $40.00 for VueScan. Hoping there is a driver that would allow me to use my current software, without purchasing VueScan.

  • 1
    Did you try to repair permissions with Disk Utility already? I had a similar issue and repairing permissions solved it. – nohillside Oct 28 '13 at 9:52
  • Thanks patrix, I tried your suggestion, but it didn't solve my problem - although it looked like it might. I restarted just in case, but to no avail. – Mark Waterman Oct 28 '13 at 10:41
1

There are four options at present and being told you can't have the new thing without paying for an old thing to work means many people will resent the $40 option and be angry:

  1. Pay the money and keep running Mavericks with VueScan to scan.
  2. Don't pay the money and revert to Mountain Lion (or whatever previous OS works with your peripherals).
  3. Get a new scanner.
  4. Wait for someone else to provide a driver that either does more than VueScan or costs less than VueScan.
0

had the same problem, no need for additional software, on mac go to applications folder look for MP Navigator, create an alias and put on desktop, when you want to scan a doc just launch MP Navigator and scan from app, hopefully canon will update driver soon for mavericks, at least this way you dont have to buy additional software.

-1

I've downloaded the most recent version of MPNavigator from canon.com to be able to scan with my Canon MP830 again under Mavericks.

-2

Couldn't wait for hp solution bought VueScan and all scanning problems solved

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

You must log in to answer this question.

protected by Community Feb 22 '14 at 15:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .