My Spotlight index got corrupted, preventing me from searching messages in Mail.app. I added my HD to Spotlight's privacy list to delete the index. I then removed it from the privacy list so Spotlight would reindex the drive from scratch.

I have done this before with no real problem.

However, this time Spotlight appears to be stuck. It's been "Estimating indexing time" for about 6 hours now.

What can/should I do?

  • 1
    possible duplicate of Why does my Spotlight index get corrupted?
    – Studer
    Sep 2, 2010 at 19:36
  • Well, I asked that question too, this is a separate problem. Now I can't get Spotlight to index my drive. Sep 2, 2010 at 21:01
  • Question about the answer (seem to be unable to post a comment though I'm logged in): The "the_name_you_have_identified_before"; is this "MacintoshHD" in the case of the answer? Just want to get this right! Maybe the initial "answerer", or someone who this worked for could answer this question for me. Many thanks. :)
    – Drewdavid
    Nov 7, 2012 at 19:34

1 Answer 1


You can try to temporarily disable Spotlight, removing its files and then reenabling it.

The process to do this involves executing Terminal commands, so please pay attention and triple check each step.

Open a Terminal.app (/Applications/Utilities/Terminal.app) and type:

cd /Volumes
ls -l

Examine the output of that, one should be your “broken” Volume. Once you have it identified, proceed with these steps, all in the Terminal. The first time you execute a command, your password may be required, this is normal.

The output may look like:

lrwxr-xr-x   1 root    admin     1 Sep  2 12:23 MacintoshHD -> /

So the name you’re after is “MacintoshHD”.

Step Number One: Disable Spotlight for your Drive.

sudo mdutil -i off "/Volumes/the_name_you_have_identified_before"

Step Number Two: Remove the indexes from the Drive.

sudo mdutil -E "/Volumes/the_name_you_have_identified_before"

Step Number Three: Eliminate all Spotlight Files from the Drive. (two commands)

cd "/Volumes/the_name_you_have_identified_before"
sudo rm -fr .Spotlight-V100

Be careful with the last command, make sure you type it exactly as it appears.

Step Number Four: Re-enable spotlight in the Drive.

sudo mdutil -i on "/Volumes/the_name_you_have_identified_before"

Now this should trigger a Spotlight complete re-indexing. You have to be extremely patient with it. Spotlight sometimes appears to be frozen but it’s really indexing. It’s best to leave it overnight and be patient.

  • Thanks Martin - its re-indexing now, will let you know how it goes. Sep 3, 2010 at 0:59
  • I let it run overnight, drive is now fully indexed, thanks! Sep 3, 2010 at 12:13
  • Glad it worked! Good luck! Sep 3, 2010 at 22:06
  • 1
    I have this problem, but can't make this fix work. I type "sudo mdutil -i off /Volumes/Macintosh HD" Since that is what my drive was identified as, but get the answer Error: invalid path /Volumes/Macintosh'. Error: invalid path HD'. Even if I exchange the blank between Macintosh and HD for an _ or just removing the blank, I can't make it work. What am I doing wrong?
    – user31452
    Oct 7, 2012 at 20:42
  • 1
    @JonteOttoman Try putting "/Volumes/Macintosh HD" between quotes. Oct 9, 2012 at 23:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .