1

I normally use private key authentication to SSH into my mac via an iOS client. I recently upgraded to Mavericks, and started noticing the client prompting for a password rather than trying the private key first. My old /etc/sshd_config had disabled password authentication ("PasswordAuthentication no, ChallengeResponseAuthentication no"), but it looks like the upgrade process to Mavericks reset these two values to yes.

Is anybody else seeing this change? Is there any documentation on this? It seems like a significant security issue to reenable SSH password authentication by default.

1
  • Is it possible that you are providing us the output of a ssh -v? Edit: This is maybe true. I rember, that Mavericks changed my httpd.conf to default. Also ls -l /etc/sshd_config shows me, that the last modification date is the day I installed Mavericks -rw-r--r-- 1 root wheel 4062 Oct 22 23:44 /etc/sshd_config
    – napcae
    Oct 28, 2013 at 2:21

1 Answer 1

1

I had the same problem and found the answer here: Mavericks update broke ssh key-based authentication

Basically, you can't use authorized_keys2 anymore (an old default). Rename the file to "authorized_keys" and it should work again (it did so for me).

mv ~/.ssh/authorized_keys2 ~/.ssh/authorized_keys
2
  • What you describe was a separate issue; my authorized_keys was already labeled as such. My most immediate problem (re-disabling password authentication) was easy to fix by editing sshd_config. More what I was trying to ask for with this post was an explanation of why the update to Mavericks re-enabled password authentication.
    – Chris C
    Nov 15, 2013 at 16:41
  • @ChrisC: Because Apple. They also re-enabled other security features (install from Any Source was turned off by the update; I had to go re-enable it).
    – Dannid
    Nov 19, 2013 at 0:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .