0

After connecting MacBook Pro running 10.8 to video project, the system crashed and after restart it booted into recovery (OS X Utilities).

I tried to fix the problem with checking disks and disk permission, everything was fine. Selecting Macintosh Hard disk as the "Startup Disk" did not alter anything. Zapping PRAM did not fix. The system even could not restart to Safe Mode.

I finally used the 7-days-ago Time Machine backup to restore the whole Macintosh hard disk. It finished successfully, but after selecting the language it boot again to recovery, and now "Startup Disk" application shows no disk to be selected.

I am sure about the backup that was created in healthy condition. This situation is very rare on this Mac and I face this condition for the first time.

Does anybody have any suggestions?

1

It sounds like the file system is damaged. Have you tried running Disk Utility, and selecting 'Repair Disk'?
Restoring from Time Machine will not repair the file system.

  • Thanks, as I stated in my question I have already repaired disk, it says disk is OK. – Ali Oct 27 '13 at 16:35
  • Well, the partition is not being recognized as a startup disk, which indicates either a problem with the file system (the disk is not set to be bootable) or with the OS files. You could try reinstalling the OS – Hobbes Oct 27 '13 at 16:49
  • Do you think restoring BaseSystems.dmg would help? – Ali Oct 27 '13 at 16:55
  • No. BaseSystems is meant for use on a recovery disk. – Hobbes Oct 27 '13 at 17:27
  • Note that you can reinstall the OS without overwriting your settings etc. This would be a simple, low-risk way to improve the situation. – Hobbes Oct 28 '13 at 8:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .