I've got a Snow Leopard 8GB USB stick that I got from my MacBook Air. Now that Mavericks is available, I'd like to update that USB stick with Mavericks.

I can't seem to be able to format that disk:

$ diskutil list
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     Apple_partition_scheme                        *8.1 GB     disk1
   1:        Apple_partition_map                         30.7 KB    disk1s1
   2:         Apple_Driver_ATAPI                         2.0 KB     disk1s2
   3:                  Apple_HFS Mac OS X Install        7.7 GB     disk1s3

I've tried the Disk Utility, it recognises the USB stick as an optical disk, and it refuses to erase it (I guess because my MacBook Air doesn't have an optical drive).

I've tried the following:

$ sudo fdisk -i /dev/disk1
fdisk: could not open MBR file /usr/standalone/i386/boot0: No such file or directory


Do you wish to write new MBR and partition table? [n] y
fdisk: /dev/disk1: Permission denied
$ sudo dd if=/dev/zero of=/dev/disk1
dd: /dev/disk1: Permission denied
$ sudo diskutil eraseDisk jhfs+ newdisk /dev/disk1
Started erase on disk1
Unmounting disk
Error: -69877: Couldn't open device

What else can I do? I'd like to erase it and format it as HFS+ (journaled).


1 Answer 1


The Apple-provided system restore USB stick is read-only. There are a few un-official tools you can use to make it into a 'regular' USB stick if you search. More information here.

  • I tried to run their software in a Windows 7 virtual machine without success. I'll try on a real Windows machine when I'll find one. Thanks a lot! Commented Oct 27, 2013 at 14:45
  • It worked like a charm! I'm impressed, thanks a lot. Now I have to get back to my Mac in order to flash Mavericks on the stick. Thanks! Commented Oct 29, 2013 at 8:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .