4

I have a mid-2012 MacBook Pro. (13-inch, 8gb memory.) I work remotely and spend a lot of time working from coffee shops and other places with public Wi-fi.

Lately - for a couple of months now - I've noticed that I'm getting far more problems with Wi-fi connectivity than normal. My wi-fi connection will drop, I'll be unable to connect ("A connection timeout occurred") or the connection will be hopelessly slow.

This is happening so often, on so many different networks, that I'm starting to think that the problem is with my laptop and not with the coffee shops.

How would I even begin diagnosing this problem? I have no idea. I downloaded an app called Little Snitch which displays information about what's using the Internet connection but I can't see anything unusual which might be clogging the bandwidth.


For what it's worth, here's the information about my Airport card from System Profiler:

Software Versions:
  CoreWLAN: 3.4 (340.18)
  CoreWLANKit:  2.0.2 (202.11)
  Menu Extra:   8.1 (810.11)
  configd plug-in:  8.5 (850.252)
  System Information:   8.3 (830.5)
  IO80211 Family:   5.3 (530.5)
  Diagnostics:  2.1 (210.25)
  AirPort Utility:  6.3.1 (631.4)
  Interfaces:
en1:
  Card Type:    AirPort Extreme  (0x14E4, 0xF5)
  Firmware Version: Broadcom BCM43xx 1.0 (5.106.98.100.17)
  MAC Address:  5c:96:9d:83:bd:5d
  Locale:   ETSI
  Country Code: FR
  Supported PHY Modes:  802.11 a/b/g/n
  Supported Channels:   1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140
  Wake On Wireless: Supported
  AirDrop:  Supported
  Status:   Connected
  • Very similar issues here with mid 2012 mb air. Apple support forums are not helpful. – Ben Taber Nov 5 '13 at 3:51
  • 1
    Changing the MTU settings (see this page) seems to have helped. – GMA Nov 5 '13 at 4:21
3
+100

Since I wrote this post my Internet problems seem to have gotten a lot better. As far as I can remember, I only made two more changes. I can't say for sure which one of these helped, or if either them helped at all and maybe there was some other factor I'm forgetting, but they may be worth a try:

  1. I changed my DNS settings to use Google's Public DNS. I can't remember what they were previously, but I definitely remember playing around with my DNS settings a few months ago so this may have been the culprit.

  2. I changed the automatic MU settings, following the instructions on this page.

Hopefully someone will find one or both of these to be helpful!

1

After lots of fumbling I discovered that the wifi speed is inversely proportional to the CPU temperatures. I installed TG Pro and found that, without altering the internal fan speed or using external cooling, the CPU's would approach 200 F after about 30 min of on time. With TG Pro I was able to increase the internal fan speed (from the built in speed of 1299 rpm to 3392 rpm) and that reduced the CPU temps to 102 F and the wireless speed was my "normal" 75 mbps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .