58

I've been able to add a Google Calendar (CalDAV) account to OS X Calendar (v6, Mountain Lion 10.8.5) without problem, and all my own calendars show up.

Is there a way of seeing calendars others have shared with me (these show up under 'Other Calendars' in the Google Calendar website settings)?

(Same situation on my iPhone.)

3 Answers 3

83

Yes, this question is answered by google here:

https://www.google.com/calendar/syncselect

You can click on the link and select shared calendars you wanna sync with your device.

4
  • you're welcome. i just had the same problem few days ago. :)
    – user60625
    Oct 26, 2013 at 13:30
  • I tired your solution, but it does not seem to be working. How long does this change take to take affect? Dec 31, 2015 at 21:30
  • 4
    I just tried it and it works perfectly. How long it takes depends on how often Calendar.app refreshes. I have it at 15 minutes, but you can force refresh with ⌘R.
    – ailnlv
    Feb 18, 2016 at 17:01
  • This solution does not work properly any more. These calendars all now appear in separate windows under the Window menu in MacOS Calendar (they do not even appear in the same window as each other). This is useless of course b/c point of an integrated calendar is to see which events conflict, and when we're available.
    – Avram
    Apr 9 at 16:59
0

You could use a Calendar Program like Informant for macOS. it allows you to combine numerous calendars into a single app.

0

I thought I would follow up on my comment above with a different answer that really did fix this problem for me.

The originally accepted answer has a major flaw - for me at least - these days (I don't know if it was always like this): If you add a shared google calendar that way (by accepting an invitation), it shows up in Google Calendar under "Other Calendars". When I follow that link, and then check off the calendar in question, it creates a completely new, independent calendar Window in Mac OS Calendar, under the Window menus. This window doesn't have any of my other events, and these events aren't in my main calendar.

The following procedure does get the shared calendar events to show up in my main calendar window. I'm on a Macbook Pro running Big Sur (yes, it's very old at this point):

  1. On the google calendar invite email, click "Add this calendar"
  2. Go to calendar.google.com & find the new calendar under "Other Calendars" (in the bottom right, at the time of this writing)
  3. Hover over it to reveal the ... menu & click Settings (It's actually a vertical stack of three dots)
  4. In the Settings pane, scroll down to where it says Public address in iCal format
  5. Copy that entire link (double-clicking on it selected the whole link for me)
  6. In Calendar on my Mac, select File -> New Calendar Subscription
  7. In the following pop-up, for "Where:" select "iCloud"
  8. Set the other options as you like & accept the dialog box (I don't remember if it was Add, OK, or something else)

Now the other calendar's events appear in my main calendar window along side all my other calendars. This also caused it to appear on my iPhone with no extra work.

I suspect that it will work if you choose the other "Where" (My Mac), except that won't get it onto other Macs or iOS devices.

Note: In some of my searching, I found some leads saying that the solution is to have full ownership permissions on the shared calendar, so that it will show up in Google Calendar under your calendars instead of Other Calendars. I did not pursue this as it required coordination with someone else, and I don't know if she would have agreed to make me a full owner.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .