16

After installing Mavericks over Mountain Lion, my vertical scrolling is wiggly (jerky) on rMBP.

Similar as in iOS, when scrolling with two fingers on touchpad down or up, a smooth motion "locks" the scroll to vertical scroll only. After upgrading to Mavericks, vertical scroll does not "lock" and will also wiggle horizontally.

This makes scrolling in Chrome and Safari painful because browser will make go back or forward in history when trying to scroll. Occasionally the screen will also jump a few pixels up or down because it's recovering from the horizontal shift.

Any advice ?

  • Good description! I searched for "jerky" rather than "wiggly"! I also find this very annoying. I'm also running Firefox 25.0 which does seem to be locked vertically. Possibly not a perfect solution, but I'll be using Firefox. – user60764 Oct 27 '13 at 22:46
  • Updated description. I'd also be more than happy for a way to access the underpinning "inertia scrolling" settings. They are hidden somewhere in osx. I've seen it a while back, but can't seem to find it now :( – Artur Bodera Oct 28 '13 at 0:01
  • Hi Artur, "inertia scrolling" are in System Preferences > Accessibility > Mouse & Trackpad > Trackpad options. – user60764 Nov 3 '13 at 22:31
  • I don't want to disable or change inertia scrolling. It does not affect what I'm describing. – Artur Bodera Nov 3 '13 at 23:41
  • 1
    Hmmph, seems the question is locked and can't be answered anymore, but I have another solution. The popular keyboard customization tool Karabiner (formerly KeyRemap4MacBook) has a setting for this. In that application, just enable "dynamic scrollwheel direction fixation" (from the search bar in the "ChangeKey" tab of the app, just search for that term and the option should appear). This will fix the issue OS-wide; given how terrible OS X's keyboard/mouse control panel is in general, I highly recommend using Karabiner (for both this and other gripes). – Hayden Schiff Jan 7 '16 at 4:50
3

Please do NOT accept this answer as the correct one. Leave this question open for as long as it takes to get a proper solution. I don't want the bounty.

I made a quick app which hacks together some basic vertical-only scroll lock support. It basically tells the system to ignore small horizontal movements when scrolling in a mostly vertical direction.

You can download the app from http://kapeli.com/ScrollLock.zip. The source code of the app is available at https://github.com/Kapeli/Mavericks-Scroll-Lock.

I have no idea how well it works, only barely tested it, but it will prevent horizontal movement when your scroll

  • How does this answer the question? Does it document there issue or somehow let someone know they do or do not have a problem? – bmike Jan 26 '14 at 6:12
  • My answer is about an app that "re-enables" scroll locking on Mavericks. The question is about scroll locking not working properly on Mavericks. My answer makes it work. – bogdansrc Jan 26 '14 at 10:16
  • Aah - you are re-implementing some filtering on the raw scroll events to suppress horizontal movements that fall below a threshold. Somehow I was focusing on the vertical part not being smooth instead of horizontal input not being suppressed. Thanks for posting the code! – bmike Jan 26 '14 at 16:04
1

Try this:

defaults write -g NSScrollViewRubberbanding -int 0

It disables “rubber-banded” scrolling systemwide and also fixes that weird behaviour on chrome/safari

  • Doesn't help with jerky scrolling and horizontal drifting. – Artur Bodera Nov 21 '13 at 15:12
  • Well, it works for me, I can now scroll chrome perfectly and without those “jumps” – Sergey Stolyarov Nov 21 '13 at 18:18
  • This worked for me, should be marked as correct answer. Are those changes persisted when using Time Machine or will I have to this every time I format my system? – Roberto Dec 30 '13 at 20:52
  • hmm weird, it seems to be working for some websites only. For me, store.steampowered.com is not good :( – Roberto Dec 30 '13 at 21:16
1

If you go to System Preferences > Trackpad, you can customize the settings to your liking. The screenshot below shows the More Gestures window and if you uncheck the first one, Swipe between pages, it should take care of the symptoms that you're having.

Trackpad Settings

  • I like this feature, I don't want to disable it. This question is not related to the existence of this feature, but to the change in its operation introduced in OSX 10.9 Mavericks. – Artur Bodera Jan 22 '14 at 10:50
  • @ArturBodera I agree with you, I like the feature too. As a result I've had to practice being very deliberate with my scrolling and over time I've become fine with it. From experience though, if you disable this feature, your problem will go away, but you will have to live without this function. – JaKXz Jan 22 '14 at 13:42
  • I refuse to acknowledge that :) I've had the same feeling and I tried to learn to "carefully navigate my fingers in a perfect vertical axis", but it's just silly. Even with extra care, I'm just imperfect human being and so it happens that sometimes my macbook is skewed 0.05 degrees on my lap from the center line of my body, or I'm just tired, or in a hurry ... and then, disaster happens! I hate it esp. when it happens when filling a long web form and I lose all changes. It was working perfect in Mountain Lion, it works perfect in iOS, so there must be a way to get it back! – Artur Bodera Jan 22 '14 at 17:57
  • I've disable that feature for chrome: defaults write com.google.Chrome AppleEnableSwipeNavigateWithScrolls -bool FALSE, it's working not as expected for most of time. – Sergey Stolyarov Feb 15 '14 at 5:16
  • @SergeyStolyarov do you mean to say "it works as expected most of the time"? – JaKXz Oct 10 '14 at 21:38
0

Go to System PreferencesGeneralShow scroll bars: Always.

This fixed the sideways lock issue for me in Safari. However, I still find that scrolling is a bit choppy. (In Firefox it's a complete epilepsy-inducing disaster.)

  • Doesn't help me, unfortunately. Scrolling is still hardly usable on screens with both vertical & horizontal scroll :( – Pavel Alexeev Oct 30 '13 at 9:35
  • I don't want scroll bars. I want to have scrolling with ver/horizontal locking as it used to be in Mountain Lion (and how it's always been in iOS) – Artur Bodera Nov 3 '13 at 23:41
0

It seems that it can be fixed by opening AutoCAD, if you have it.

Source: https://discussions.apple.com/message/23531982#23531982

  • Frankly, I'd consider running and keeping a 300MB application running in background if it fixed it... though I don't think I'll be paying $1000 to get it :) – Artur Bodera Jan 20 '14 at 17:55
  • @Artur It might be a long shot, but if you're at university, you can get it for free. – grg Jan 20 '14 at 17:59
  • Nah, I'm not ... The good new is, Apple might be able to reverse-engineer whatever is causing the "proper behavior" when running AutoCad and fix it in the OS. Can't wait for a real solution. – Artur Bodera Jan 20 '14 at 18:44
  • That is bizarre! Hopefully someone can do this while running fseventer and find out if a setting is being changed. – NReilingh Jan 22 '14 at 5:43
  • @bogdansrc Could you take a look at this one? I believe you'd be able to make more sense out of it... – Artur Bodera Jan 22 '14 at 10:51

You must log in to answer this question.

protected by Community Jan 26 '14 at 6:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .