15

I have been several months using my mid-2010 15" MBP connected to a Dell U2711 through a miniDisplayPort-DisplayPort adapter, without any trouble cranking the resolution up in Mountain Lion to it's full 2560x1440.

I have just updated my laptop to Mavericks, and I'm not able to use the full resolution of my monitor anymore. I have done several tests, either with the lid open and closed, or trying to force the discrete GPU through gfxCardStatus

Is anyone experiencing this same behaviour? Anything I could try? Possible workarounds?

  • 1
    I don't have the reputation to post an answer on a protected question, but here's what worked for correcting the resolution on my 1920x1200 Planar PX2611W: Open the display settings from System Preferences. First, choose "Best for Display." Then, hold down the option key, and click "Scaled." You'll have more scaled options to choose from, and you can now select the appropriate resolution for your display. – Kevin C. Feb 7 '14 at 4:03
7

Finally I found this. Looks like the default EDID configuration for Dell displays is not quite right.

On that post there's also a ruby script that suposedly generates the right file for your display, but it ended up screwing even more my resolution.

I downloaded the file from the first post, and after copying it to /System/Library/Displays/Overrides and rebooting, my display was showing again its awesome full resolution. The files are suposedly to correct issues with U2713H and U2713HM, but it worked with my U2711 also.

Hope this helps someone as it helped me.

| improve this answer | |
  • did not work for me on macbook pro 15" retina display>Mavrick, I tried to connect through DVI or VGA, not working... reboot resulted the same resolution list. – user61293 Nov 1 '13 at 16:05
  • 3
    I've read around (not sure where, sorry) that clicking on the radio button of "Adjusted" resolution while pressing down the alt key presents you with more resolutions than usual... give it a try, just in case – listik Nov 4 '13 at 9:30
  • The script did the job for me! I've seen this a long time ago when I was looking into color calibration, but I would never have thought that that also fixes my resolution issues that just popped up from one day to the other. Thanks so much! – eWolf Nov 30 '14 at 11:09
  • I have been using two older Dell E228WFB monitors for years with no problems on a Mac Mini. Today the thunderbolt display was showing a reduced resolution. Ultimately I was able to fix it by setting and resetting the Display Profile under the Color tab. Holding down the Alt button when clicking Display -> Scaled was also helpful. – Chris Conover Feb 24 '15 at 17:28
  • Having the same issue the full resolution is not showing up even after trying that fix. ireckon.net/2013/03/… – Benedikt Feb 9 '16 at 16:00
2

This Ruby script generates a custom override for your monitor. Save it as patch-edid.rb to your user folder, and from Terminal run ruby patch-edid.rb. Copy the generated file into /System/Library/Displays/Overrides/ and reboot.

#!/usr/bin/ruby
# Create display override file to force Mac OS X to use RGB mode for Display
# see http://embdev.net/topic/284710
# 
# Update 2013-06-24: added -w0 option to prevent truncated lines

require 'base64'

data=`ioreg -l -w0 -d0 -r -c AppleDisplay`

edid_hex=data.match(/IODisplayEDID.*?<([a-z0-9]+)>/i)[1]
vendorid=data.match(/DisplayVendorID.*?([0-9]+)/i)[1].to_i
productid=data.match(/DisplayProductID.*?([0-9]+)/i)[1].to_i

puts "found display: vendorid #{vendorid}, productid #{productid}, EDID:\n#{edid_hex}"

bytes=edid_hex.scan(/../).map{|x|Integer("0x#{x}")}.flatten

puts "Setting color support to RGB 4:4:4 only"
bytes[24] &= ~(0b11000)

puts "Number of extension blocks: #{bytes[126]}"
puts "removing extension block"
bytes = bytes[0..127]
bytes[126] = 0

bytes[127] = (0x100-(bytes[0..126].reduce(:+) % 256)) % 256
puts 
puts "Recalculated checksum: 0x%x" % bytes[127]
puts "new EDID:\n#{bytes.map{|b|"%02X"%b}.join}"

Dir.mkdir("DisplayVendorID-%x" % vendorid) rescue nil
f = File.open("DisplayVendorID-%x/DisplayProductID-%x" % [vendorid, productid], 'w')
f.write '<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">'
f.write "
<dict>
  <key>DisplayProductName</key>
  <string>Display with forced RGB mode (EDID override)</string>
  <key>IODisplayEDID</key>
  <data>#{Base64.encode64(bytes.pack('C*'))}</data>
  <key>DisplayVendorID</key>
  <integer>#{vendorid}</integer>
  <key>DisplayProductID</key>
  <integer>#{productid}</integer>
</dict>
</plist>"
f.close

Source: EmbDev.net, topic “Dell U2713H on Mac: forcing RGB mode instead of YCbCr”, post #3027030

| improve this answer | |
  • I ran the ruby script but terminal gave me this error patch-edid.rb:11:in <main>': undefined method []' for nil:NilClass (NoMethodError) – user68540 Jan 26 '14 at 15:01
  • Thanks, this made my day. I had trouble with my 2014 MBA and a Dell U2713H. I had a 1080p resolution that was gross. Now I still 'only' have 1080p, but it looks smooth. Also I had really off-putting colors before and now it looks great. Thanks! – fancy Jan 11 '15 at 17:21
  • Using the solution for the exact issue for my Planar PX 2710MW, the resultant resolutions does not include the advertised 1920x1080 but only at the most 1440x900. Any idea? – Meng Lu Aug 3 '15 at 23:11
1

I have a solution that worked for me. Running MBP retina 15" early 2013 with Dell u2713hm.

This solved the problem:

http://embdev.net/attachment/167830/U2713H_U2713HM_Mac_EDID_override.zip

The problem can be solved by overriding the EDID data of the display (http://en.wikipedia.org/wiki/Extended_display_identification_data) in order to tell OS X that the display only supports RGB. This can be done by reading the EDID with ioreg -l, modifying the offending bits (see the specification in the Wikipedia article), and creating a display config override file for OS X. I have attached such a file for the U2713H and U2713HM; just extract it and move the contained folder into /System/Library/Displays/Overrides. After a reboot, the monitor should show that RGB colors are used. For other monitors with the same problem, the files won't work, but in principle the solution is the same.

Source: http://embdev.net/topic/284710#3027030

| improve this answer | |
0

LOL you don't have to do all that nonsense. Just hold down the "option" key when you press the radio button for "Scaled" -- then all the options will appear. This is totally non-intuitive but it tells you this if you bother to read the Help screen that comes up when you press the (?) icon in the corner of the Displays preference pane.

| improve this answer | |
  • 2
    Aha. Turns out sometimes the maximum resolution is not appearing among the options when pressing alt. Hence the need of "all that nonsense". But thanks for your answer. – listik Oct 3 '15 at 15:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .