I just installed GIMP (from the dmg on the GIMP website) on my new MacBook Pro running Mavericks. Unfortunately, when I went to go export/save an image, the keys that are hotkeys in GIMP (e.g. 1 is 100% zoom) are captured as hotkeys while typing in the name to save the file. Captured in that they both are not typed in the save name input and it messes with what is being done in the GIMP project.

Anyone know what the cause might be or how I might fix it?

up vote 2 down vote accepted

The problem was fixed in GIMP 2.8.10, so if you're running into this problem please download a newer version.

I am experiencing the same problem and while I haven't found a solution, I have found a better workaround: just disable all keyboard shortcuts:

  • Click on Edit> Preferences
  • Go to the "Interface tab"
  • Click on the "Remove all the Keyboard shortcut".

It is a known bug with Mavericks and Gimp, but there is no solution yet. For me, Gimp opened once on Mavericks and refuses to do anything now. It seems to be very broken at the moment

the key 'J' doesn't seem to be a hotkey. For now, I just save files as J and choose the file extension manually below (using the mouse). At least I can save/export files. Then I manually rename the J-file it in Finder. Ugly but works :)

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.