9

I just upgraded my mid-2012 MacBook Air to 10.9. Now whenever I scroll down a page, the effect is very choppy. The scrolling seems to stop and start very quickly. Also, sometimes the left part of the page will scroll down but the right part of the page will stay put for a fraction of a second. The net effect is very flickery and distracting.

Any ideas on how to fix this? Slighly different case, but this guy was able to solve a very similar problem (external monitor) by opening AutoCAD (what the heck?).

I also tried resetting the SMC as recommended here. Still no luck.

  • You could try disabling the animations for scrolling by running defaults write -g NSScrollAnimationEnabled -bool false (and reopening applications). – Lri Oct 25 '13 at 17:40
  • I tried this, but would not say that I saw a difference. Thanks though. – DanHickstein Oct 25 '13 at 20:44
  • I have the same issue. Whats interesting is, I noticed this issue begin occuring when Mavericks was close to being released. This was a few months before the launch date and I was still running Mountain Lion. So naturally, I decided to do a fresh install with Mavericks, but it didn't fix the problem :( Edit: Another interesting symptom, its much much worse on my system when I use an external non Apple mouse. Trackpad and Magic Mouse seem to work well. – JimCricket Dec 3 '13 at 20:42
  • just a side effect of mavericks superior memory management, i.o.w. not complete file is loaded all at once. to test scroll all the way down, then up and now down again and observe. – Ruskes Mar 13 '14 at 20:50
3

Try System Preferences -> Energy Saver -> Automatic graphics switching -> Off

  • This option does not exist. – mareoraft Oct 16 '15 at 2:36
2

Not a cure, but here is a temporary solution.

  • Go to Apple menu at the top left corner of your screen, then go to System Preferences.
  • Under the personal heading click General,
  • Under Show scroll bars, click Always.

This worked for me.

  • Thanks for the suggestion, but unfortunately, this did not make any difference in my case. I actually already had the scroll bars set to "Always". I tried the other setting but this did not make any difference. – DanHickstein Oct 29 '13 at 14:50
2

Finally figured out the scrolling issues:

  1. Go to System PreferencesAccessibilityMouse & Trackpad
  2. Go to Trackpad Options…
  3. Set Scrolling to max speed and 'with inertia'
  • That did not work to fix my scrolling (tried previously), but I'm glad that fixed your problem! – DanHickstein Dec 8 '13 at 1:19
  • This seemed to help with mine. I'm not sure it's totally fixed but it's an upgrade from before – Joe Phillips Jul 16 '14 at 0:38
1

I just performed a clean install of Mavericks and the scrolling works perfectly now. Also, the whole system works much faster now. I wish there was a less annoying solution, but this works :)

1

I experience this issue occasionally. Currently I'm running El Capitan, and I have had this issue in prior OSes. Today just shutting down my MacBook completely and restarting it alleviated the problem. For now...

0

I'm suspecting vmware fusion cause the problem. Because everytime I open fusion, the problem will comes out (in short or long time after fusion opened). And the funny thing is if I open vmware fusion and parallels desktop together, I don't have the scrolling problem!

  • I didn't have vmware installed, so I don't think that was the problem for me. But good to hear that you've tracked it down in your case! – DanHickstein Dec 5 '13 at 0:01
0

Today I'm using parallels desktop a whole day and the problem not happens yet. I did clean install couple of times before. Really I think there's a software causing this problem, because there's no answer from Apple about this annoying problem.

Hope the problem won't occur again with your fresh Maverick ;)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .