10

Responsive scrolling is causing a lot of issues for me. It's nice when it works, but it's lagging a lot sometimes, especially in Chrome.

Anyone found out a way to disable responsive scrolling and make scrolling behave like in 10.8? Either globally or per-app.

During the "Optimizing Drawing and Scrolling on OS X" WWDC video, the Apple Engineer uses what looks like an AppleScript file to disable responsive scrolling globally, so it is possible, but I can't figure out how.

  • 1
    The "responsive" scrolling is absolutely terrible for me on a 2009 MacBook. I had great scrolling performance with Mountain Lion, but now the scrolling is so choppy that I can't scroll into view what I want to be looking at. It's really frustrating. – OregonTrail Oct 25 '13 at 15:20
  • That perfectly describes the issues I am having ... For what it's worth, I'm on a 2012 MacBook Pro. – bogdansrc Oct 25 '13 at 15:35
  • @bogdansrc In terms of Chrome have tried deleting it & then reinstalling it ? – Simon Nov 4 '13 at 12:35
  • @Simon yes, tried that. This is also on a fresh install of Mavericks. – bogdansrc Nov 4 '13 at 13:19
4
+250

Firstly I am posting this as possible helpful info rather than a solution. Which may get some one in the right direction.


I found this in the What's New in OSX which goes into explaining what and how Responsive Scrolling works.

At the bottom there is also a note saying how to disable it per app for testing purposes.

But I do not see this option in my own built apps or any others.

Responsive Scrolling

Responsive scrolling is an AppKit enhancement that makes scrolling smoother. This involves two significant changes to the way your app draws content:

Scroll views ask their child views to draw extra content outside their normal view area so that the content can be immediately made available for scrolling purposes. This additional window backing is stored in purgeable memory to minimize additional paging. The scrolling thread attempts to redraw the view at 60 frames per second, but it backs off if the app is unable to keep up. Scrolling events are processed on a background thread. Most apps automatically receive this responsive scrolling behavior. However, some views must explicitly opt in, including layer-backed views, custom scroll view or clip view subclasses that override drawRect:, NSSurface-based document views, transparent document views, and document views that override the lockFocus method.

For views in which responsive scrolling is automatically enabled, the behavior change should be entirely transparent to you as a developer. However, if your app exhibits any unusual behavior while scrolling, please file bugs.

Note: You can temporarily disable responsive scrolling for testing purposes by choosing File > Get Info on your app in Finder. After changing the setting, you must quit and relaunch your app. For more details, see AppKit Release Notes for OS X v10.9.

I had a look at the appkit release notes -Responsive Scrolling which goes into more detail.

There are conditions which should stop Responsive Scrolling being assigned to an App. One of them is:

The application links on 10.7 or prior (the application must link on Mountain Lion or higher to support this feature)

Which I take to mean if the App is built to also run on 10.6 then it will not have this feature added.

Chrome AFAIK will run on 10.6 upwards. But I suspect the downloader is downloading a version for you current system.

Possibly a version built for 10.6 only would disable it in Chrome.


UPDATE* But as bogdansrc points out in the comments. There is no single build for 10.6


I did try:

defaults write ~/Library/Preferences/com.google.Chrome isCompatibleWithResponsiveScrolling -bool NO

But the isCompatibleWithResponsiveScrolling is for a nsview sub class and I do not really expect it to work. I also am not getting this problem so I cannot tell.

  • This looks like an interesting hack – New Alexandria Nov 4 '13 at 15:08
  • The "works on 10.6 => does not have responsive scrolling" assumption is incorrect. This is about which SDK the app links against. You can have an app link against the 10.9 SDK and work fine on 10.6. As far as I know, the general approach is to link on the latest SDK, so most likely Chrome does that. If it didn't, it wouldn't have responsive scrolling. There are no multiple versions of Chrome based on what OS X version you are running. That's silly. – bogdansrc Nov 4 '13 at 16:41
  • What I am basically trying to say and interpret from apples note incorrectly or correctly is if the Base sdk is 10.6 and not linked to any above that then as far as I understand it the app will not have RS. You start of so nicely but then spoilt it by being insulting with "Thats silly”. A simple "There is no 10.6 only Chrome" would have sufficed. Apps can have builds for older OSs that will not install or run on the latest OS. Which is what I was thinking of. – markhunte Nov 4 '13 at 19:31
4

UPDATE (7.XI.2013 after call to Apple Care):

I needed also:

1) resetting PRAM (after turn-off, turn-on while holding CMD+ALT+P+R up to second gong), how to on your mac: https://support.apple.com/kb/ht1379

2) resetting SMC (after turn-off, turn-on while holding SHIFT+CTRL+ALT(option) + POWER) how to on your mac: https://support.apple.com/kb/HT3964

THE BELOW SETTING SHOULD BE: with inertia


It is probably NOT the permanent solution, but fast and comfortable hack in comparison to system reboot.

It worked for me. Sorry that screenshots are in Polish. Anyway, you should manage it thanks to images/icons.

First open Accessibility from System Preferences

enter image description here

Then in Touchpad/Mouse settings, click touchpad button

enter image description here

Then play with/without inertia.

enter image description here

  • I think the responsive scrolling is different from the inertia scrolling... – DanHickstein Nov 1 '13 at 1:15
  • 1
    @DanHickstein it's kind of workaround. – andilabs Nov 1 '13 at 1:27
  • Hmmmm, I think that the responsive scrolling is a new thing to make scrolling work at 60 fps, as discussed here: developer.apple.com/library/mac/releasenotes/MacOSX/… I'm not sure it has anything to do with the inertial scrolling. – DanHickstein Nov 1 '13 at 1:30
  • Maybe not. But I and few users relized that playing with interial allows to get rid of problem with frezzing in Chrome. – andilabs Nov 1 '13 at 1:38
  • 2
    Disabling inertial scrolling is not an option for me (I hate non-inertial scrolling). Also, responsive scrolling is unrelated to inertial scrolling. You still get responsive scrolling with or without inertia. – bogdansrc Nov 4 '13 at 16:37
1

I asked John Siracusa on twitter:

https://twitter.com/siracusa/status/394988398009925632

@siracusa Have yu fnd a way to trn off "responsive scrolling" in mavericks? It feels strange

His answer was very succinct:

https://twitter.com/siracusa/status/394988398009925632

@davidmarsh No.

I guess that doesn't mean you can't disable it, just that John doesn't know a way to turn it off.

  • 2
    If John Siracusa doesn't know how, it's very likely that it is not possible. arstechnica.com/apple/2013/10/os-x-10-9 – user9290 Oct 29 '13 at 2:05
  • 1
    An Apple engineer did it using what looked like an AppleScript during the "Optimizing Drawing and Scrolling on OS X" WWDC session. The video is available at developer.apple.com/wwdc/videos. This doesn't mean it's still possible in the latest build of Mavericks. – bogdansrc Nov 4 '13 at 16:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .