This issue started happening after I updated to OSX Mavericks.

I have an external monitor connected to my Macbook Pro (2010), and everything works just fine and dandy.. until my Mac doesn't have any activity for a bit and turns off the screen (NOTE: not the whole Mac is asleep at that point, it's just the screen).

Then when I swoop around on my trackpad to wake it back up, it won't recognise the external monitor the way it used to. Suddenly the arrangement is flipped (i.e. it's now below my Mac rather than above it), and the resolution is switched to 800x600 rather than the normal 1680x1050.

When I then pull the plug and plug it back in (while my Mac and its screen are wide awake), it finds its old configs again and fixes the resolution and arrangement.

Has anyone experienced anything similar, or is there a fix available? Or should I just consider this an unresolved bug, report it to Apple and hope for the best?

  • I've been having this problem since before Mavericks. It seems to happen 100% of the time now though...
    – Hudson
    Nov 3, 2013 at 16:14
  • I can't add an answer due to this question being protected. I fixed this issue by going to Disc Utility and hitting "Repair Permissions". I was getting similar issues with my keyboard and mouse not being recognized. I hope this fixes those as well. Jan 21, 2014 at 21:48
  • For me, I can fix this without disconnecting/reconnecting cables if I select Turn Display Mirroring On in the menu bar, and then turning it back off again. (OS X 10.9.3)
    – Nate
    May 29, 2014 at 7:43
  • @Nate I can confirm that this works at the moment as well (OSX 10.9.3). Nice to have a software 'reset' rather than having to pull cables.
    – Joost
    May 30, 2014 at 14:56
  • I am having this same problem to 10.10.2 with a 5K imac. The external display is connected via a thunderbolt to DP adapter. I am using the mirror/unmirror trick with success
    – t1m0
    Feb 5, 2015 at 13:43

3 Answers 3


The fix I've adopted is to visit the Display section of the System Preferences. Hold the Option key to reveal the Detect Displays button. Click it.

The connector on my laptop has ended up a bit loose after years of unplugging and reinserting. Using System Preferences is probably kinder on it, until some kind of fix is forthcoming.

(There used to be a menu bar icon for displays, which included the Detect Displays option - but now that I have need of it, it appears to have been removed. Apple knows best, I suppose, and who am I to argue. Perhaps I am just plugging it in wrong.)

  • As an update, I'm now running OS X 10.9.2, and this problem seems to have been fixed. (And... I'm still plugging in my monitor in exactly the same way. So it looks like it wasn't that after all.)
    – Tom Seddon
    May 5, 2014 at 0:46
  • 3
    Problem still exists for me in 10.9.3. This solution doesn't do anything (for me).
    – Nate
    May 29, 2014 at 7:36
  • I had this issue on OSX Yosemite 10.10.5, working with an external DELL monitor via HDMI. Though it seemed like an unlikely gamble, switching to DVI (via a DVI/thunderbolt adapter) was the fix for me. Something worth trying! (As long as you don't require this connection to carry audio to your monitor speakers, which only HDMI supports)
    – paulkore
    Oct 9, 2015 at 15:13
  • This worked, not sure if this will continue to work after restarts. Jun 27, 2017 at 17:48

I have almost the same experience - after sleep my second display isn't available at all. Thanks for the tip of unplug - replug the display (firewire) - that solved the problem - but I will hate to do it all the time. My setup: iMac 27" 2011 and Lacie 526 display.


I would have most of my windows halfway or mostly offscreen.

Unplugging and replugging before I wake seems to solve this problem also.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .