I've a MacBook Pro Retina Display.

The username & password for the proxy settings for HTTPS keeps resetting by itself every few mins.

If I enable "Proxy server requires password" below & put in my username-password, after 2 or 3 mins, it'll automatically reset and the text fields becomes inactive.

As a result, the pop-up asking for username-password keeps coming back every few mins (which is very annoying).

However, this doesn't happen for the HTTP one.

How do I fix it?

2 Answers 2


This worked for me. Here's what I did:

The solution is to ensure that you have working proxy settings saved in the system keychain, not just your personal login keychain.

So when you next get one of these dialogs:

  1. Note the server name that is requesting authentication, the port (usually 8080) and if it is an http or https request. Typically it will be something in the form https://someproxyserver.someorganization.com:8080

  2. See if you already have an entry for that server in your login keychain. If not, make one manually, (being sure to enter the whole thing as per the example above with the :8080 at the end). Typically that there needs to be two separate keychain entries per proxy server, one for http and a second for https, though syncdefaultsd only uses https.

  3. Once you have login keychain entries for the proxy server, double-click them and ensure that under Access all applications are allowed, and that your user name is saved.

  4. Now for the fun bit. Option-drag and drop these entries into your system keychain. Click on the system keychain, and confirm that they are there, and that all the settings are exactly right.

For good measure, do a shift-restart then a normal restart.

You should now get no more annoying dialogs for that particular proxy server. If your proxy server has more than one alias, or if you have several, then whenever you get a new unidentified dialog, repeat the above.

Source: Apple Support Discussions thread


I just went through a similar thing with VPN configurations. I have about 10 configs and it seemed like half couldn't retain the password and I would be prompted for it.

My solution was to open Keychain Access, and search for the config in question and delete it's keychain entry. Then re-enter the password in the Network preference pane and hit "apply". That created a new keychain entry and I no longer got prompted for the password.

  • I tried doing that but still the issue persist. The entry in the keychain itself gets deleted when the proxy username/password resets
    – ptamzz
    Oct 29, 2013 at 9:37
  • Bummer. Thanks for responding, and good luck on getting a fix. Oct 29, 2013 at 23:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .