10

Since I updated to Mavericks two days ago on my late 2008 13-inch MacBook (first unibody aluminium), I have huge difficulties using Mail. When Mail is running, everything slows down extremely (I constantly see beach balls and spend most of the time waiting for any of my inputs showing an effect, not just in Mail but with everything). The activity monitor shows that "Mail" and "com.apple.internetaccounts" both have 90%+ under "% CPU", and most of the time Mail is "Not Responding". The Mail application doesn't show any window during maybe the first hour after trying to open it, and once I see the main window, everything is so slow that even opening an e-mail can - if it works at all - take a loooot of time. Two or three times, I even got a complete freeze, the cursor not moving anymore, the fans (which were running constantly before) shut down; the only thing I could do was holding the power button for five seconds.

I have no firewall app running and have looked into my log file which is available here: http://s000.tinyupload.com/index.php?file_id=55665966095442984994

When I force quit Mail and com.apple.internetaccounts, things run smoothly, so the problem seems to be limited to the Mail application. What might I be able to do to avoid having to force quit Mail and have it respond more smoothly and not hang up?

  • Have you checked the Console for Entries with more details to the Problem? Do you have any Firewall-App running (like Little Snitch)? Have you tried to Boot in 'Save Mode'? – J.C. Oct 25 '13 at 6:43
  • I don't know how to interpret console entries. I uploaded a log-file in the edited version of the question above. – Corsin Pfister Oct 25 '13 at 9:42
6

Thanks for uploading the Logfile. There are several entries which could describe the Problems, f.e.:

25/10/13 4:29:58.408 pm WindowServer[125]   disable_update_timeout: UI updates were forcibly disabled by application "Mail" for over 1.00 seconds. Server has re-enabled them.
25/10/13 4:30:12.256 pm WindowServer[125]   disable_update_likely_unbalanced: UI updates still disabled by application "Mail" after 15.00 seconds (server forcibly re-enabled them after 1.00 seconds). Likely an unbalanced disableUpdate call.

and

25/10/13 4:36:30.089 pm WindowServer[125]   common_reenable_update: UI updates were finally reenabled by application "Mail" after 392.86 seconds (server forcibly re-enabled them after 1.00 seconds)
25/10/13 4:37:26.568 pm com.apple.IconServicesAgent[437]    main Failed to composit image for binding VariantBinding [0x159] flags: 0x8 binding: FileInfoBinding [0x359] - extension: jpg, UTI: public.jpeg, fileType: ????.

and

25/10/13 4:45:13.084 pm Mail[408]   xpc __securityd_create_connection_block_invoke got event: Connection interrupted

and

25/10/13 4:45:21.796 pm com.apple.internetaccounts[463] An instance 0x7fcb64cef770 of class IMAPMailbox was deallocated while key value observers were still registered with it. Observation info was leaked, and may even become mistakenly attached to some other object. Set a breakpoint on NSKVODeallocateBreak to stop here in the debugger. Here's the current observation info:
<NSKeyValueObservationInfo 0x7fcb64cf0620> (
<NSKeyValueObservance 0x7fcb64cf0750: Observer: 0x7fcb64f28160, Key path: uidNext, Options: <New: NO, Old: NO, Prior: NO> Context: 0x12131544b, Property: 0x7fcb64cf05f0>
)

Some of the entries describe Timeouts because of syncing errors. How to fix them?

I would cleanup the Cache of the Mailaccount either by moving the Cache Folder or be deleting and recreating the IMAP-Account.

If you want to cleanup the Cache you have to:

  1. Quit Mail
  2. got to ~/Library/Mail/V2
  3. Find the Folder for your IMAP-Account in the Folder "V2". It should be named something like "IMAP-you@email.address"
  4. move the Folder for your IMAP-Account somewhere else, f.e. to the Desktop
  5. start Mail again. It should be syncing the Mails from your IMAP-Account to your Computer in a normal fashion.

If that does not help you could try the second approach: deleting the IMAP-Account and recreating it.

Try that and post your results please.

  • Removing stuff in the V2 folder finally helped. After playing around with removing different stuff, I found out that I only had to remove "Accounts.plist" in the V2/MailData folder to stop Mail hanging up. Afterwards, I could simply reactivate all accounts in the OS Preferences --> Internet Accounts, except for one (of my four) IMAP accounts. This one account had the same e-mail address as associated with my iCloud, and I think this produced the conflict. I couldn't activate this IMAP-account (errors shown). I deleted and recreated it. Now everything works fine. – Corsin Pfister Oct 26 '13 at 8:53
  • I have the same problem, the only thing i can do is turn of mail, and use the gmail, not that I like this solution! I hope this gets fixed soon @Corsin: did you just delete the "Accounts.plist" file??? I read the Mail in Macericks changes and Mail is always running something in the background. – user60629 Oct 26 '13 at 13:01
  • This might make a decent follow on question. 1. The asker has accepted the above answer and 2. people can't really answer you unless you ask a question since comments don't work well to add new threads to an existing topic. – bmike Oct 26 '13 at 14:52
1

If you reinstated your mail from an older Mountain Lion (or previous) installation, you might have moved quite a lot of crud, which is incompatible with Mavericks.

I once had a similar problem (What is com.apple.mail.plist and why was it slowing Mail down?), which I resolved removing a couple of plists. In general, you might want to:

  1. open console
  2. run Mail.app

and see what console says about Mail.app. That would be my first port of call.

0

What kind of email accounts is your copy of Mail checking? Are any of them Google GMail accounts? There is a well-documented situation whereby Apple Mail under Mavericks will automatically start downloading all your gigabytes of Google Gmail archives all over again, leaving you with duplicates of everything.

What kind of network activity do you see while Mail is open? If there are massive downloads happening, this could be the culprit.

Mail in Mavericks Changes the GMail Equation, TidBITS, 22 October 2013

You must log in to answer this question.

protected by Community Oct 28 '13 at 21:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .