4

In Mavericks (OS X 10.9,) remote (Apple cloud-based) dictation works normally.

But, after check-marking the "Use enhanced dictation" checkbox in System Prefs --> Dictation & Speech, when I attempt to use dictation, the mic window pops up, it shows normal audio input on the blue "level" meter in the mic icon, but nothing happens at the text insertion cursor.

(Yes, I did already complete the download of the required ~750MB language pack, and I've restarted my system several times.)

Suggestions for how to resolve this?

  • I have exactly the same problem. – Hengjie Nov 1 '13 at 22:28
5

It's possible the Enhanced Dictation language pack was corrupted when it was downloaded. You could try deleting it and re-downloading it.

First, turn off Enhanced Dictation in System Prefs > Dictation. When you uncheck the box a panel will slide down that you can just Cancel (which will turn Dictation off). Next, open Finder and press shift-command-g simultaneously. In the dialog box paste the following and click go:

/System/Library/Speech/Recognizers/

In the Recognizers folder there will be two folders. Delete (or rename) the folder called SpeechRecognitionCoreLanguages. It will ask you for your password to delete (or rename) the folder. After that you can go back to System Prefs > Dictation and turn Enhanced Dictation back on. It will show you your download progress in the bottom left corner of the System Prefs window.

  • 2
    Tried your suggestion, unfortunately problem remains exactly as before. – gosmond Oct 25 '13 at 18:34
  • I tried the suggestion but I do not even find the Recognizers folder. – esmitex Nov 16 '13 at 14:54
1

I had same problem and did the reinstall and still no fix, however I did notice in the "dications and speech" tool in System preferences that there is a drop down menu under the mic labelled "internal microphone". Click it to once again select internal mic in the options that drop down and the mic will now work.

  • The question already states that the microphone is working fine, including within the Dictation function. Sound is getting to the subsystem, it's just not processing that sound. Suggest you remove your answer. – gosmond Nov 5 '13 at 23:02
  • 1
    @gosmond - this is an old answer, but it actually worked for me. I had the same issue where the microphone seemed to be working, as you described, and the levels went up and down, but it would not respond. Switching microphone input had an immediate effect. – beroe Nov 5 '14 at 5:47
0

Resetting the cache of the language rec (deleting com.apple.SpeechRecognitionCore in caches of user library) helped me to reactivate a language where the mic reacted, but no transcription took place.

For more option look at https://discussions.apple.com/message/24229993

0

I know this is an old question, but I've had the same issue (enhanced dictation doesn't work, ordinary Apple server dictation does) and just solved it via a bit of research elsewhere. Me? Mac Mini mid 2010, El Capitan, maxed out memory, very basic Logitech AK5730 mike connected via USB. The fault? Apparently, there is a coding error somewhere in the recognizer download for UK English (unaware if Apple are working on a fix though).

After trying everything here, I found that little gem of info, switched off the Enhanced module, added another language (U.S.English), switched Enhanced back on, and it forced Dictation to download the new language recognizer. Took about three minutes to download and set itself up.

Switched Enhanced Dictation back on et Voila... It works perfectly. All I have to do is put up with 'color' and 'honor' etc, but, coming from Salford, UK English wasn't recognizing half of what I was saying anyway! Hope this helps.

0

I eventually succeeded by deleting the plist file ~/Library/Preferences/com.apple.assistant.plist and the cache at ~/Library/Caches/com.apple.SpeechRecognitionCore, as described here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .