2

I'm using TotalTerminal on 10.9 Mavericks and while it's not great, it's the best quake terminal I've found right now. I usually show/hide the visor using command-escape but unfortunately can't seem to pull this off as I'm being told there's an existing universal shortcut for this key combination.

I've gone through the keyboard preferences shortcuts and can't find anything that maps to command-escape. The only thing I can think of is that this used to be front-row (which is no longer installed by default on new macs).

Does anyone know how I can set command-escape manually in total terminal via config file? I'm happy doing that by modifying the apple keyboard shortcuts and erasing whatever is mapped their now or editing a totalterminal config.

Thanks in advance

1
  1. Run plutil -convert xml1 ~/Library/Preferences/com.apple.Terminal.plist.
  2. Quit Terminal.
  3. Edit the plist in a text editor:

    <key>ToggleVisor</key>
    <dict>
      <key>KeyCode</key>
      <integer>53</integer> <!-- escape (see Events.h) -->
      <key>Modifiers</key>
      <integer>9437184</integer> <!-- command -->
    </dict>
    
  4. Terminate the cfprefsd process from Activity Monitor.

  5. Open Terminal.

Preference files are cached in 10.9, so if you edit a preference file directly, just quitting and reopening the application does not apply the changes. You can also run defaults read com.apple.Terminal instead of terminating cfprefsd.

0

Sorry, but I can't leave a comment - not enough reputation...

The answer given by Lauri works, but you have to make sure that the cache of that .plist file is cleared. I achieved it by simply restarting the computer after editing the file.

  • 1
    Welcome to Ask Different! Feel free to edit such information into the answer directly. – grg Jan 5 '14 at 7:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .