I was able to read and write NTFS filesystems normally in Mountain Lion, but after the upgrade this stopped to work.

I installed ntfs-3g and fuse4x using homebrew in Mountain Lion and followed the instructions displayed by homebrew to finish the installation of fuse4x kernel extension.

To try to solve this problem I removed ntfs-3g, fuse4x and fuse4x-kext and reinstalled them. But this didn't solve my problem.

Does anyone know how to solve this? Thanks.


13 Answers 13


I found the proper way to do this (also works for Yosemite):

Install Homebrew and cask if you don't already have them:

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"
brew install caskroom/cask/brew-cask

Uninstall any previous versions of osxfuse (unsigned kexts are banned now):

brew cask uninstall osxfuse

Update Homebrew and install osxfuse and ntfs-3g

brew update
brew cask install osxfuse
brew install ntfs-3g

You need to create a symlink for mount_ntfs, in order to make drives mount automatically:

sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original 
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs
  • 2
    Note that not everyone has homebrew installed by default. Could you please add a link to the homebrew website explaining that you need to install that to get the brew command? Commented Nov 22, 2013 at 12:34
  • works like a charm ! Commented Nov 24, 2013 at 16:21
  • ntfs-3g is a FUSE filesystem, so it runs in user space - while it's free and probably works fine (used to use it on Linux a lot), you may find a commercial NTFS driver such as Tuxera's is faster if you do a lot of read/write to NTFS filesystems.
    – RichVel
    Commented Dec 3, 2013 at 6:23
  • 2
    $ sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original Password: mv: rename /sbin/mount_ntfs to /sbin/mount_ntfs.original: Operation not permitted
    – Cœur
    Commented Jun 28, 2015 at 10:26
  • 2
    If you get following error while installing ntfs-3g "Error: No available formula for ntfs-3g", try installing it by running: brew install homebrew/fuse/ntfs-3g
    – dsr
    Commented Jul 18, 2015 at 23:37

This is so easy and you don't need to install any 3rd party application or driver. No reboot required.

  1. Find out the name of your "Volume"
  2. Open Terminal
  3. Create or Update your /etc/fstab file. Replace "My040Passport" with the name of your "Volume". you can do this by typing sudo vi /etc/fstab into Terminal. You will be prompted for your password.

    # Warning - this file should only be modified with vifs(8)
    # Failure to do so is unsupported and may be destructive.
    LABEL=My\040Passport none ntfs rw,auto,nobrowse
  4. Unplug your external harddrive and then plug it back in

  5. You will NOT see your HDD listed in the Finder anymore you must open it in from within Terminal with the below steps.
  6. Open Terminal, enter 3 commands below and use your own Volume name in the 3rd command

    cd /Volumes
    open My\ Passport

    Command 1 will Change your current directory.
    Command 2 will list Volumes, the one you're interested in will be listed here.
    Command 3 will open your Volume in Finder.

  7. Since you won't see the HDD in the Finder, let's add a link to it onto your Desktop. Open Terminal, enter this command replacing the Volume name, and replace the destination as well if desired.

    ln -s /Volumes/My\ Passport/ ~/Desktop/hdd
  • To bad that no icon is displayed on the desktop. I wonder why that is.
    – Martin
    Commented Mar 6, 2014 at 20:44
  • @grgarside You can add it to your desktop with just one more command. sudo ln -s /Volumes ~/Desktop/Volumes via this article
    – mpickens
    Commented Mar 7, 2014 at 1:03
  • I have also tried this solution from some blog and it worked!!! However, until I was copying using terminal, all was working fine. As soon as I tried copying using Finder to a folder, containing minimum of 50GB of Data, in external HDD, content of the target folder went empty without any notification or error. :( Now that folder always seems empty.
    – vikas
    Commented Apr 26, 2014 at 5:41
  • 1
    This is the best way to write to NTFS volumes. Using 3rd party applications like Paragon NTFS or osxfuse will mess up your modules which leads to frequent kernel panics. I had the same issue when trying Paragon extFS for ext4. See this thread for related issues: apple.stackexchange.com/questions/29842/… (the thread is for ext4, but ntfs is basically the same when you're using a 3rd party application)
    – thibmaek
    Commented Apr 16, 2015 at 21:43
  • 2
    There is small drawback....you need to repeat this step for every single drive you insert...a little bit of a pain, but well...no biggie... Commented May 7, 2015 at 18:32

I had the same setup as you, and since upgrading to 10.9 I can't write to NTFS. The solution I ended up going with (at least for the short term,) was to use Paragon's NTFS for Mac® OS X 11. It seems to work fine, and has a 10 day free trial.

Hopefully a better method will be found soon, but I got tired of messing with it.

Another option that I didn't try was to edit the /etc/fstab file. The following is from NTFS Write Support On OS X Mountain Lion:

  • Uninstall other 3rd-party NTFS software, like Paragon, Tuxera or NTFS-3G.
  • Edit /etc/fstab (you can do this with sudo vi /etc/fstab) Add the following line: LABEL=”VOLUME_NAME_WITHOUT_QUOTES” none ntfs rw,auto,nobrowse
  • Now, just unmount and re-mount the disk
  • I tried the other approach you mentioned, no luck:(
    – Steve
    Commented Oct 29, 2013 at 16:43
  • 1
    Here is what I did for my Bootcamp drive: LABEL=BOOTCAMP none ntfs rw,auto,nobrowse. It works well on 10.9 Maverick. If you are using Seagate HDD, you can also download the free Seagate NTFS driver Commented Nov 2, 2013 at 23:38
  • 1
    after this, volume is not displaying in finder window. to access it goto "/Volumes" from Menu->Go->"Go To Folder" menu. Also you can add this volume to sidebar to future easy access..
    – tanaydin
    Commented Nov 3, 2013 at 21:32
  • 2
    Just as a warning to others, I used this and then had backblaze backing up the drive (constant activity for days) and eventually my drive freaked out, crashed OSX, and even after I removed the drive I was not able to get OSX to be stable again until I removed the /etc/fstab file. I don't recommend this option on Mavericks Commented Dec 11, 2013 at 4:51
  • @HaiFengKao Does that only work with Seagate drives?
    – Szabolcs
    Commented Jan 26, 2015 at 1:04

I used a combination of macfuse-core-10.5-2.1.9, and ntfs-3g-2010.10.2-macosx on OS X Mavericks and I am able to write to a NTFS drive.

  • Firstly Install macfuse-core-10.5-2.1.9
  • Then install ntfs-3g-2010.10.2-macosx
  • After installations, let's open the NTFS-3G
    • System Preference > NTFS-3G
    • Click [enable]
  • Finally, let's unmount your target NTFS disk and mount it again

Even if you go the TimeOut message, you are in the right direction already. Let's try to create file and folder to your NTFS harddrive.

  • Can you detail the steps to arrange this combination? Simply installing both doesn't work for me.
    – Cœur
    Commented Nov 17, 2013 at 19:38
  • Thanks, I was missing the "Click [enable]". For the TimeOut message, you got FuseWait I think.
    – Cœur
    Commented Feb 2, 2015 at 6:32

Install the NTFS-FREE for OS X Mountain Lion 10.8.2 software and reboot you Mac. This worked for me on OS X Mavericks.

  • This didn't work for me.
    – Cœur
    Commented Nov 17, 2013 at 19:37
  • Doesn't work on Mavericks for me either.
    – iano
    Commented May 4, 2014 at 15:31
  • Worked great for me on OSX 10.9.3 (Mavericks). Thanks for the recommendation
    – user456584
    Commented Jul 1, 2014 at 0:29

Using MacPorts:

sudo port install fuse4x ntfs-3g
sudo ntfs-3g /dev/disk2s1 /Volumes/ntfsmountpoint

This answer is aimed at latest compatibility for OS X 10.11 El Capitan.

  1. Install latest osxfuse (3.x.x) from https://github.com/osxfuse/osxfuse/releases or from Homebrew with brew cask install osxfuse.

  2. Install latest NTFS-3G (2015.3.14) from brew (homebrew/fuse/ntfs-3g).

As follow:

brew install ntfs-3g
  1. Link NTFS-3G to boot after temporary disabling System Integrity Protection.

As follow:

[reboot by holding CMD+R to get in recovery mode]
csrutil disable
[reboot normally]
sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.original
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs
[reboot by holding CMD+R to get in recovery mode]
csrutil enable
[reboot normally]

installation alternative

For building NTFS-3G from source edge (2015.9.30): check this answer


I don't know about Mavericks, but in Lion I have write access to NTFS file systems using FUSE for OS X, a free & open-source alternative to commercial solutions by Tuxera or Paragon.

Notice this is NOT the old MacFUSE project; which is no longer being maintained.


Your in luck! let's do it the safe way
For seagate hard disk owners alone, download the free driver here!

1.Fuse/NTFS-3G drivers is a good option.
2. If you're a geek there are ton of other options using terminal commands. But be warned, you can run into issues during future updates etc.

If it is for a pen-drive(or any smaller USB sticks), you could simply format it to FAT32
For larger hard drives, FAT32 is not a good option, since it has file-size limits etc


Just install the latest version of the old MacFuse for OS X.

What I did was to reinstall my NTFS-3G and download and install Fuse for OS X.


Following Pawel's answer fixed the issue for me in Mavericks

brew update
brew install fuse4x
brew install ntfs-3g
sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.orig
sudo ln -s /usr/local/sbin/mount_ntfs /sbin/mount_ntfs
brew info fuse4x-kext

Dont symlink fuse4x even though the linking fails as ntfs-3g also tries to create the same link.


The following worked for me on Mavericks(10.9.5). I had formated the NTFS USB key on a windows 7 machine. Assuming that the device is named 'usbkey' and the disk shows up as /dev/disk1:

$ sudo umount /Volumes/usbkey
$ sudo mkdir /Volumes/usbkey
$ sudo mount -t ntfs -w -o rw,auto,nobrowse /dev/disk1 /Volumes/usbkey
$ mount | grep usbkey
/dev/disk1 on /Volumes/usbkey (ntfs, local, noowners, nobrowse)

I was able to copy files to and from the NTFS formated drive using Terminal, and if I ran 'open .' from the /Volumes/usbkey location in Terminal.


This script worked for me on Yosemite. No 3rd drivers needed! http://sourceforge.net/projects/native-ntfs-osx/files/

Not the answer you're looking for? Browse other questions tagged .