I have updated my (Late 2009) Mac Mini to Mavericks. "About This Mac" shows "OS X 10.9 (13A603).

However, I have not been able to update iTunes to version 11.1.2. The App Store shows that the update is available. It also shows several instances of it in my update history. After clicking "Update", the button quickly changes to "Installed". Closing and re-opening the App Store shows the update as available again. Checking within iTunes shows it is at version 11.1.1, so not actually updated. (Repeated several times)

Mac App Store showing iTunes 11.1.2 as both available and recently installed.

The iWork apps (Pages, Numbers, and Keynote) have actually been updated, showing the correct versions. However, I occasionally one or more will also show up in the App Store as available as well; the behavior is similar to iTunes. If I scroll down, there are multiple instances in my update history as well.

Things I have tried:

  • Rebooting.
  • Selected "Store -> Check for Unfinished Downloads..." This appears to re-install the iWork apps, as evident by progress bars in Mission Control, even when they are not listed as needing an update. It does not seem to do anything for iTunes.
  • Delete iTunes and reinstall. OS X does not allow iTunes to be deleted. I have not yet tried this with iWork.
  • Selected "Debug -> Reset Application" (there is a hidden menu)
  • Selected "Debug -> Clear Cookies"
  • Selected "Debug -> Show Download Folder", and deleting the files there. A subsequent check for unfinished downloads puts them back.

These have had no effect, unless I described it above.

What can I do to get the updates properly installed?

Update: After letting the issue sit for a few days, the App Store no longer shows the iTunes update as available; but iTunes itself is still at 11.1.1.

1 Answer 1


I just solved this on my Macbook Pro 15" Retina (Intel Iris, late 2013) by downloading iTunes from Apple's website and installing 11.1.2 that way. Now the App Store shows everything as up to date.

  • Heh, since the normal update system works pretty well, it didn't occur that the old-fashioned installer would still be available! iTunes does now show as 11.1.2! - Thank you for your answer!
    – mbmcavoy
    Commented Oct 26, 2013 at 16:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .