113

I have a MacBook with Cinema Display, I have my dock on the MacBook screen side and my menubar is set to Cinema Display. In 10.8 this worked well, when I pressed cmd-tab to switch apps the task switcher would come up on the "main" Cinema Display.

In 10.9, however, it's always on the MacBook's screen, very annoying. Is there a setting I've missed?

166

I believe this coincides with the Dock's location. Just tested it on my MacBook Air, connected to a non-Apple external display, and whenever I moved the Dock from screen to screen the Application Switcher would follow.

You can summon the Dock on your big display by dragging the cursor to the bottom of it's display, essentially dragging down at the bottom. After a second the Dock should pop up. Once the Dock is on the desired display press commandtab to summon the Application Switcher.

  • 7
    The trouble is, my dock is on the side of the macbook screen not bottom, so it doesn't travel with screen. Eh, I guess it's not fixable at the moment. – Dmitry Shevchenko Oct 23 '13 at 20:58
  • 8
    @DmitryShevchenko Ah, gotcha. Mine always stays at the bottom so I hadn't encountered that. It seems the workaround then is to change it's position to be at the side of the Cinema Display that is furthest from your MacBook. My big display is on the left and my MBAir display is on the right. When I position the Dock on the left I get the Application Switcher on my big display. When I position the Dock on the right (moving to my MBAir display) I get the Application Switcher on the right. Hopefully that makes sense. – Mr Rabbit Oct 23 '13 at 21:07
  • 7
    For me, the dock shows up on both screens and it appears the widget will show up on the screen where I last opened an app from the dock. The person who decided not to show the widget on all screens should be fired in IMHO. Terrible UX. – antonagestam Jul 24 '15 at 13:47
  • 2
    @antonagestam: actually (for me, at least) it's the last display that I've activated the dock on. I have it auto-hidden, but when I hover over it to show it, that display becomes the 'primary app switcher widget' one. – Bobby Jack Oct 30 '15 at 13:43
  • thank you this was absolutely driving me nuts having my CMD+Tab menu appear on my secondary menu for what I thought was no reason. Thought this was a huge UI bug but should've known better. – anon58192932 Nov 1 '16 at 14:08
29

Maverick has this "Displays have separate Spaces" switch in the Mission Control settings.

In my experience, if it's enabled, then the alt-tab menu gets displayed on the display that used the dock for the last time. IE, if you clicked on the dock bar on the 2nd display, next time you do an alt-tab, the menu is going to show up there.

If you disable the "Displays have separate Spaces" options, you fix this annoying thing, but you get the old full screen support that Mountain Lion had, where the full screen app in one display, disables every other display.

  • 1
    Great answer - I just clicked something on the dock on the screen I wanted my cmd-tab menu to appear on and it worked! – Henrik Ekblom Aug 28 '14 at 12:19
  • 1
    I have the dock set to auto-hide. For me on Yosemite (10.10.3), it was enough for me to hover over the dock to make it appear on the screen I wanted. Then the cmd-tab app switcher appears on that same screen. – Christian Long Jul 8 '15 at 19:18
13

So far, the best way to accomplish this for people who prefer the dock on the side is to change the dock position to be at the side furthest from your MacBook.

This is done by right-clicking on the dock, choosing "Position on Screen" (if you do not see this option, try right-clicking lower down on the dock) and either choosing left or right - whichever is furthest from your Macbook.

For clarity and user-friendliness, this was extracted and augmented from Mr Rabbit's comments above.

  • 1
    Note for those who have 2 external displays - if you have either: Macbook Screen Screen; or Screen Screen Macbook; the only way to make the app switcher appear in the middle screen is to use "Bottom" position for the Dock. – tokes Mar 12 '14 at 22:16
  • Not really. I have one monitor on each side... – ratskin Aug 20 at 9:33
6

Unchecking and then rechecking "Displays have separate Spaces" options in Mission Control System Preferences restored the Alt+Tab interface back to the primary monitor, for me (on Mavericks 10.9.5). I did not have to log out, as suggested by the OS.

  • Nice one!! The dock was on the larger display for me but Command+Tab was still coming up on the laptop. This fixed it. (In El Capitan.) – Rob Nov 6 '15 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .