6

I had synchronized my personal Facebook account on OS X Mountain Lion in System Preferences > Mail, Contacts & Calendars through the Facebook tab. I removed it and synchronized my official account on it, but I'm still getting notifications for the personal account.

How do I remove the personal account details permanently and stop the notifications?

Update

I have upgraded my Mac to OS X Mavericks 10.9, but the problem exists on the upgraded OS X version too.

Edit

I have found another thing with my mac. This issue happens only for my official account. If i have synchronized any other accounts. It doesn't happen. Working fine. What may be the problem with this?

  • 1
    Did you check in Notification Center's Preference Pane? Isn't there a Facebook section after you activated the account? I don't write a full answer because I can't check at the moment, but I believe you can disable it there, and then create a new account. – mcdado Mar 12 '14 at 8:47
  • your response to @mcdado is not clear. Facebook does appear in the notification center. Do you see it under System Preferences > Notifications? What do you mean by "not working"? Have you attempted to disable it? – njboot Mar 17 '14 at 3:43
  • @njboot Can you get my question? Is it clear for you? If not let me know. I'll explain you clearly. – Praveenkumar Mar 17 '14 at 7:19
1

My suggestion would be to log out of the current Facebook account. Then go into your user's Library folder (holding down the alt / opt key while in the "Go" menu in Finder and you will see a new entry "Library"). In your Library folder enter the subfolder "Preferences" and delete these two files:

com.apple.accountsd.plist & com.apple.internetaccounts.plist (or just shove them over to the Desktop for testing)

Log out and back into the correct account and see if there are any notifications in Notification Center still listed. If yes, then download Onyx from http://www.titanium.free.fr/downloadonyx.php and let it do an automation where it clears all caches. When Onyx is done it will ask you to restart.

From here you should be good and there should be no trace of the original/old Facebook account. If however you notice anything still being left over, comment back with more information.

|improve this answer|||||
-1

Find it under System Preferences > Internet Accounts. You can remove Facebook account from there.Internet Accounts on Mac

|improve this answer|||||
  • 2
    No use. Have you read my question fully? – Praveenkumar Mar 12 '14 at 6:30
  • I did. I haven’t used Mountain Lion for a while and forget that is was in Mail, Contacts & Calendars section.What do you get if you open ~/Library/Internet Accounts/ with Finder/Terminal? – sayzlim Mar 12 '14 at 10:03
  • I got only No such file or directory – Praveenkumar Mar 12 '14 at 13:19
  • @praveen it shouldn’t happen if you’ve added your iCloud or Facebook account. Does that mean you don’t have any accounts currently signed in Internet Accounts section? – sayzlim Mar 12 '14 at 13:51
-1

If you don't want to mess with plist or any system configuration, just open Facebook in your browser, go to Settings -> Apps and remove permission for Mac OS X in there. It will not send to your Mac any notifications anymore.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .