19

The shortcut control-command-space in Mavericks opens a panel with Emojis. I'd like to use it for another application (Divvy), but it complains that it is already used by a system-wide keyboard shortcut. But as far as I can see there is no way to disable it in the system settings. Does anyone know of an alternative method to disable it?

9

Creator of Divvy here. I'm not sure why Divvy can't record this shortcut in the UI, but you can force Divvy to use this shortcut:

  1. Quit Divvy.
  2. Launch Terminal.app and paste this command, on one line, and press enter:
    defaults write com.mizage.direct.Divvy globalHotkey -dict keyCode 49 modifiers 4352
  3. Also, paste this command, on one line, and press enter:
    defaults write com.mizage.Divvy globalHotkey -dict keyCode 49 modifiers 4352
  4. Restart Divvy.

There's no risk to running these commands, you can always change the shortcut again in the UI. Hopefully I can update the recorder to properly capture these shortcuts in the future.

  • This works perfectly for me. Thank you for taking the time to figure out this issue! – buddahbrot Apr 27 '14 at 2:07
  • OMG this saved my bacon, I only started noticing this when I recently went to setup a new iMac, my MBP had this shortcut set and I didn't initially have trouble setting it before, but that may have been pre-Mavericks, and now I'm running both my MBP / iMac on Yosemite beta. But this definitely resolved this headache. – Scott Kingsley Clark Sep 19 '14 at 22:36
  • 1
    It should be noted somewhere in this answer that this fix works best in conjunction with the fix below so that the special characters functionality isn't lost – David Hollman Nov 10 '14 at 18:01
11

You can change the shortcut from System Preferences:

Either three periods or an ellipsis character should work.

You can disable the shortcut by modifying ~/Library/Preferences/.GlobalPreferences.plist:

defaults write -g NSUserKeyEquivalents -dict-add 'Special Characters...' '\0'

Quit and reopen applications to apply the changes made with the defaults command.

  • Looks like this works, but it seems that even after applying the fix (and verifying that the system wide shortcut is indeed removed globally), Divvy still refuses to use that combination as its global activation shortcut... I've sent an e-mail about this to the author of Divvy. – Erik Allik Nov 30 '13 at 15:36
  • 3
    A note for Yosemite (OS X 10.10) and later: instead, use defaults write -g NSUserKeyEquivalents -dict-add 'Emoji & Symbols' '\0' – jrhorn424 Dec 2 '15 at 6:12
3

This all seems to be for older OS's I have run the terminal command but for Yosemite it looks like just assign the name to "Emoji & Symbols" for all apps. Would be nice to not assign any shortcut to this and remove it but you can't save no shortcut and it will not let me save and then delete the shortcut (that probably wouldn't work anyway. At least it is assigned to another shortcut across all apps finally!

  • Unfortunately this does not seem to apply to international (localized) versions of OS X ... – oligofren May 8 '15 at 9:47
  • 1
    For Yosemite or later, you can completely disable the shortcut with defaults write -g NSUserKeyEquivalents -dict-add 'Special Characters...' '\0'. – jrhorn424 Dec 2 '15 at 6:14
1

If it's of any help, you can disable the replacement of emoji to emoticons in the Messages app like this: Edit > Substitutions > Emoji menu. Not sure if this frees up the Ctrl+Command+Space shortcut, though.

  • such menu item does not seem to exist on my 10.9 – Erik Allik Nov 30 '13 at 15:26
  • He's talking about within Messages…which doesn't answer the question – daviesgeek Oct 13 '14 at 18:59
1

I wanted to promote @jrhorn424's comment to an answer, so it's more visible.

Frustratingly, the keyboard preference pane won't let you remove a standard shortcut, only bind it to something else. You can do it in the terminal, though.

As @jrhorn424 wrote:

"A note for Yosemite (OS X 10.10) and later: instead, use defaults write -g NSUserKeyEquivalents -dict-add 'Emoji & Symbols' '\0'"

0

I use Quicksilver for this, it overrides other keyboard shortcuts by default, which is handy for pesky harder-to-manipulate default shortcuts. It can open any app with any key combination; check it out.

  • Alfred automatically overrides this shortcut too. – Dmitry Jul 14 '17 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .