9

In Mountain Lion I was able to permanently disable Notification Center, with no apparent side effects:

launchctl unload -w /System/Library/LaunchAgents/com.apple.notificationcenterui.plist
killall NotificationCenter

However, the Mavericks upgrade process restored Notification Center in all its irritating glory. Is there are reason that the upgrade reverted my disabling of Notification Center?

Can I disable Notification Center in Mavericks using the same procedure, without side effects?

6

If you start Terminal, enter

sudo defaults write /System/Library/LaunchAgents/com.apple.notificationcenterui KeepAlive -bool False

and restart, this did the trick for me in Mavericks.

  • 1
    FWIW: The old procedure has worked for me so far, though a restart is also required to prevent a completely blank panel from appearing in place of Notification Center when the mouse is moved to the far upper-right corner of the screen. – orome Oct 23 '13 at 18:20
  • 1
    This actually disables Notification Center because it changes the permissions of the plist from 644 to 600. If you change KeepAlive to false some other way that doesn't change the permissions of the plist, the NotificationCenter process is still started at login but it is not relaunched if it terminates for some reason. To undo the changes, run f=/System/Library/LaunchAgents/com.apple.notificationcenterui.plist;sudo defaults write $f KeepAlive -bool true;sudo chmod 644 $f;launchctl load $f. – Lri Nov 29 '13 at 18:59
  • This seems to disable the battery low notifications and the battery icon turning red, any way to restore those? – urok93 Apr 26 '14 at 1:51
2

Just unloading the plist still works for me:

launchctl unload -w /System/Library/LaunchAgents/com.apple.notificationcenterui.plist

If the plist is not loaded, sudo defaults write /System/Library/LaunchAgents/com.apple.notificationcenterui KeepAlive -bool False should have no effect.

0

You will have side effects if you upgrade to Yosemite (Beta 2). The notification icon on the menu bar re-appeared, but clicking it just makes the icon itself flash briefly. I am able to slide the panel from the right of my magic trackpad, but otherwise can't fix the menu bar to either fully disable or reenable it.

  • Welcome to Ask Different! If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. However, questions regarding pre-release software are off-topic. – grg Aug 23 '14 at 11:34
0

actually I came up with a much more straightforward way. Simply remove the Notification app which is located in /System/Library/CoreServices/.

To do so you first have to kill the process otherwise finder won't let you delete it since it's already running (do a little top to get its PID). Then just move the .app file to the thrash. At reboot it's as if it's never been there.

And since I simply remove the .app and don't touch any config files, I don't see how I could get any side effects (but please correct me if i'm wrong).

0

In Mavericks you cannot control the notification center, because you will make FaceTime unusable. If you get an incoming call, no window appears. So you cannot accept the incoming call. I did not check other OS Versions.

I think, there is no solution. All the code is Spaghetti. If you switch one thing off, you break another.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .